WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18756 closed defect (bug) (duplicate)

.current_page_ancestor typo in Twenty Eleven CSS

Reported by: zsero Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

It's a typo but because of the underscores and dashes it's quite hard to notice. The thing is that .current_page_ancestor is not on a wordpress page, it should be .current-page-ancestor. Note the - vs _.

In detail, instead of:

#access .current_page_item > a,
#access .current_page_ancestor > a {
	font-weight: bold;
}

it should be >>>>

#access .current_page_item > a,
#access .current-page-ancestor > a {
	font-weight: bold;
}

Attachments (1)

18756.patch (456 bytes) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 SergeyBiryukov3 years ago

  • Keywords reporter-feedback added

comment:2 zsero3 years ago

OK, then there must be a bug somewhere else, because this is what I have in my generated page using stock Twenty Eleven.

menu-item menu-item-type-post_type menu-item-object-page current-page-ancestor menu-item-105

comment:3 zsero3 years ago

  • Keywords reporter-feedback removed

SergeyBiryukov3 years ago

comment:4 SergeyBiryukov3 years ago

  • Keywords has-patch added

Ah, right. 'current-' . $queried_object->post_type . '-ancestor' is used too:
http://core.trac.wordpress.org/browser/tags/3.2.1/wp-includes/nav-menu-template.php#L436

comment:5 SergeyBiryukov3 years ago

  • Component changed from Themes to Bundled Theme
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Actually, duplicate of #18643.

Note: See TracTickets for help on using tickets.