WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18763 closed defect (bug) (fixed)

Collapsed admin menu: current menu doesn't always open

Reported by: scribu Owned by:
Milestone: 3.3 Priority: low
Severity: normal Version: 3.3
Component: Administration Keywords:
Focuses: Cc:

Description

Steps to reproduce:

  1. Collapse the admin menu.
  2. Go to wp-admin/edit.php
  3. Move the mouse over the Media icon and keep it there for a few seconds.
  4. Move the mouse up over to the Posts icon.

Result: the Posts submenus will not show up.

Demo: http://www.youtube.com/watch?v=kN5aJdMQ_2w

Happens in Firefox 7 beta.

Doesn't happen in Chrome stable.

Change History (4)

comment:1 solarissmoke3 years ago

Seems to be peculiar to Firefox (also happens in 6.0.x) - works fine in Opera and IE. Funny thing is that if you hover over/out of the parent icon 3-4 times then the submenu will start to appear again.

comment:2 duck_3 years ago

Looks like a duplicate of http://core.trac.wordpress.org/ticket/18382#comment:18

Patch available there too: http://core.trac.wordpress.org/attachment/ticket/18382/18382.fix-glitch.diff

Might be better to leave this as a separate ticket so it doesn't get forgotten.

comment:3 WraithKenny3 years ago

Also happens as a result of the responsive admin changes: If you shrink the window far enough, the menu will collapse itself, and the bug is present.

comment:4 SergeyBiryukov3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [18901].

Note: See TracTickets for help on using tickets.