WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 12 months ago

#18767 closed defect (bug) (fixed)

Trac comments seem buggy

Reported by: azaozz Owned by:
Milestone: WordPress.org Priority: highest omg bbq
Severity: major Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

Seems we have two "comment:22" http://core.trac.wordpress.org/ticket/18314#comment:22 on #18314. Tried to edit the second one but the edited content went into the first :)

Change History (19)

comment:1 nacin3 years ago

Looks like it got to 23 and reverted back to 13 with a commit from you, then proceeded to count from there.

No idea what's going on here, but I can ask barry for a database snapshot if necessary.

This would be a bug in Trac, or probably more likely, a glitch with the database. We don't have any modifications affecting this.

Leaving this open as we can manually renumber them in the DB.

comment:2 azaozz3 years ago

Yes, looks like something went wrong when the commit message was added to the comments.

comment:3 SergeyBiryukov2 years ago

More duplicate comment IDs: ticket:18785:20

Version 0, edited 2 years ago by SergeyBiryukov (next)

comment:5 ocean902 years ago

  • Priority changed from normal to highest omg bbq

This problem is still in the wild, can it be fixed? Mostly happens in tickets with many comments.

:)

comment:6 scribu19 months ago

  • Cc scribu added

comment:7 nacin19 months ago

I think I've only seen this caused by an automatic commit message. Does that sound about right? If so, I can dig into that area of the code.

comment:9 nacin19 months ago

Okay. This is caused by the Trac commit ticket updater, and it is not two consecutive commit messages, but a commit message that references multiple tickets.

Say you have ticket A with 30 comments, and ticket B with 45 comments. If you have a commit message that references both A and B, the next comment on ticket A will be 31, but ticket B will also be 31.

It seems that sometimes, it is the second referenced ticket (so, B) that screws up, while in the case of ticket:21390#comment:48, it's the first ticket that is referenced that is screwed up. It also doesn't appear to be a newer/older ticket thing. If someone can find a pattern, do let me know.

This appears to be the bug report upstream: http://trac.edgewall.org/ticket/10681. It's ultimately not very descriptive, which is why it likely hasn't gotten any attention. If we can gather enough information I'm happy to increase its profile upstream.

The commit updater code is here: http://trac.edgewall.org/browser/trunk/tracopt/ticket/commit_updater.py.

comment:12 scribu19 months ago

Yes, the first time, I inserted the ticket number in the comment field and I got an error and the comment was only posted on the other ticket.

comment:13 nacin19 months ago

Yeah, I used something added in a later version of Python than this server runs, for a particular branch of code. I'll get it fixed.

comment:14 follow-up: SergeyBiryukov18 months ago

Some recent comments and tickets don't show up in wp-trac mailing list:
https://irclogs.wordpress.org/chanlog.php?channel=wordpress-ui&day=2012-10-16&sort=asc#m64458

comment:16 nacin18 months ago

This might be fixed with an update to Trac 0.12.4. See http://trac.edgewall.org/ticket/10881. I guess we'll find out.


comment:17 in reply to: ↑ 11 SergeyBiryukov18 months ago

Replying to SergeyBiryukov:

"# was marked as a duplicate" message is sometimes posted twice

In my case, that happened when I linked a comment on the original ticket rather than the ticket itself in the comment field when closing a duplicate ticket. I got an error, as mentioned in comment:12.

Last edited 17 months ago by SergeyBiryukov (previous) (diff)

comment:18 nacin17 months ago

Seems fixed with 0.12.4.

Fixing the "# was marked as a duplicate" now too.

comment:19 nacin12 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with 0.12.4, not broken in 1.0 either.

Note: See TracTickets for help on using tickets.