WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#18780 closed enhancement (invalid)

The caption "Comment author must fill out name and e-mail" is ambiguous

Reported by: gabrielhtc Owned by: gabrielhtc
Milestone: Priority: normal
Severity: normal Version:
Component: Text Changes Keywords:
Focuses: Cc:

Description

Observation

Users tend to think that if they uncheck that option, the name and email fields will not be displayed.

Problem

The caption "Comment author must fill out name and e-mail " in the "Other comment settings" of the Discussion settings is ambiguous.

What is expected

With the current caption, users expect that the name and email fields aren't shown.

What happens instead

The name and email fields are still displayed, but they are now optional instead of being required. Some of the themes do not explain whether the fields are required or optional, so the users think that unchecking the option has no effect.

Solutions

  • Changing the caption to a less ambiguous one such as: "Name and email is optional for guests comments"
  • Make sure that the themes show clearly which field is required or not to be able to post the comment.

Change History (8)

comment:1 SergeyBiryukov3 years ago

  • Keywords ui-feedback added

comment:2 Cornel_14 months ago

  • Severity changed from normal to major

Wanted to confirm this small issue and to ask if there are any updates about it. Would be great that if the option "Comment author must fill out name and e-mail " is disabled, then mark the Name and Email fields as optional (not Required like now), or maybe don't show them at all.

comment:3 Cornel_14 months ago

  • Keywords ux-feedback needs-patch added

comment:4 Cornel_14 months ago

  • Type changed from enhancement to defect (bug)

comment:5 markoheijnen14 months ago

  • Severity changed from major to normal
  • Type changed from defect (bug) to enhancement

The severity of this ticket isn't major. Also it's an enhancement since the only thing we can do is changing the label.

The real issue is the theme you are using. If you look at Twenty Twelve the issue isn't there. I would maybe even say close this ticket as worksforme because of this.

comment:6 SergeyBiryukov14 months ago

  • Component changed from Comments to Text Changes

comment:7 Cornel_14 months ago

Yes, I agree with you, depends on the theme, also the option required can be overridden by using

get_option('require_name_email')

to detect if the option is enabled.
Had a look in twenty twelve, they are using the default form without arguments (some themes use custom mark up).
Thank you, and sorry for any inconvenience. Ticket can be closed.

Last edited 14 months ago by Cornel_ (previous) (diff)

comment:8 andrewspittle9 months ago

  • Keywords ui-feedback ux-feedback needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.