WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18782 closed defect (bug) (worksforme)

Autosave collision detection messaging never gets displayed to the editor.

Reported by: IAmWilliamWallace Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Autosave Keywords: has-patch reporter-feedback
Focuses: Cc:

Description

The message "Autosave disabled: (user) is currently editing this post." is being over written by a previous autosave message so the editor never sees the autosave error.

Steps to reproduce:

Editor A: Creates a new post and starts adding content.("A" has lock)
Editor B: Starts editing the same post and clicks save draft ("B" has lock)

Editor A: continues to make changes and autosave fires. At this point editor B has the lock and the autosave will fail and be disabled but the message is not apparent because the error will be overwritten with the default autosave message "Last edit by "

---
To fix this, the autosave messages (not errors) need to be in the control statement if ( !res.errors )

The problem existed in versions before 3.2 but this patch is for >= 3.2 since the autosave css class names changed.

Attachments (2)

autosave.diff (931 bytes) - added by IAmWilliamWallace 3 years ago.
This is for WP Version >= 3.2
autosave_16928 (1).diff (772 bytes) - added by IAmWilliamWallace 3 years ago.
This is for WP Version prior to 3.2

Download all attachments as: .zip

Change History (5)

IAmWilliamWallace3 years ago

This is for WP Version >= 3.2

IAmWilliamWallace3 years ago

This is for WP Version prior to 3.2

comment:1 SergeyBiryukov3 years ago

  • Milestone changed from Awaiting Review to 3.3

comment:2 duck_2 years ago

  • Keywords reporter-feedback added

After following the instructions I cannot reproduce this on either the 3.2 branch or trunk. I have tried with existing posts and after creating new posts (as described). I always see the large red alert shown above the editor -- this cannot be overwritten by the Javascript that is being moved in the patch as it's touching .autosave-message and not #autosave-error -- as well as the "Autosave disabled" message in the bottom right of the editor.

Are you sure this wasn't fixed by [17640] for 3.2? That commit actually replaced the longer "Autosave disabled: %s is currently editing this page." message you reference with the two I mentioned above.

comment:3 duck_2 years ago

  • Milestone 3.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No feedback for three weeks and I still cannot reproduce so closing this as worksforme. Please re-open if necessary.

Note: See TracTickets for help on using tickets.