Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18805 closed defect (bug) (fixed)

sort_column=post_name not working for wp_list_pages or get_pages

Reported by: brad2dabone Owned by: ryan
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords: has-patch
Focuses: Cc:


The sort_column=post_name parameter is no longer working in wp_list_pages or get_pages as it did in previous versions. I'm not sure which version it stopped behaving as expected (ordering posts by slug). Both functions now output the list ordered by title, not slug.

Attachments (1)

18805.patch (670 bytes) - added by SergeyBiryukov 4 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
4 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.3

Caused by [18350].

#2 @ryan
4 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [18845]:

Restore sorting by post_name in get_pages(). Props SergeyBiryukov. fixes #18805

Note: See TracTickets for help on using tickets.