WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18809 closed defect (bug) (fixed)

Live-update the admin bar comment bubble

Reported by: nacin Owned by: koopersmith
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Administration Keywords: dev-feedback ux-feedback
Focuses: Cc:

Description

This is a regression from 3.2.

Restoring the proper classes to ensure the number updates is easy. However, we can't properly localize this, as the format is now "%s Comments" rather than "Comments %s".

Patch attached restores the proper classes. Does nothing for the localization problem, which I just don't think can be solved in JS.

Attachments (6)

18809.diff (580 bytes) - added by nacin 4 years ago.
18809.hover-arrow.png (1.2 KB) - added by SergeyBiryukov 4 years ago.
18809.patch (667 bytes) - added by SergeyBiryukov 4 years ago.
18809.icon-only.png (19.5 KB) - added by SergeyBiryukov 4 years ago.
18809.tweaks.diff (1.7 KB) - added by duck_ 4 years ago.
18809.tweaks.2.diff (1.4 KB) - added by duck_ 4 years ago.

Download all attachments as: .zip

Change History (13)

@nacin4 years ago

comment:1 @SergeyBiryukov4 years ago

  1. The bubble also appears to have an arrow on hover, overlapping with the number (see the screenshot).
  2. With the current format, it's now possible to see "1 Comments" or "2 Comment".

comment:2 follow-up: @ryan4 years ago

  • Keywords ux-feedback added

Removing the word and making do with the icon would avoid the problem.

@SergeyBiryukov4 years ago

comment:3 in reply to: ↑ 2 @SergeyBiryukov4 years ago

Replying to ryan:

Removing the word and making do with the icon would avoid the problem.

18809.icon-only.png shows what it looks like with 18809.patch.

comment:4 @ryan4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [19105]:

Fix live update of comment bubble. Drop text to avoid translation difficulties. Props SergeyBiryukov. fixes #18809

@duck_4 years ago

comment:5 @duck_4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Attached 18809.tweaks.diff to fix a couple of small things.

Always add the #ab-awaiting-mod span and add .awaiting-mod and .count-$awaiting_mod. This allows the pending count to live update from 0. This is an improvement over 3.2.

Centre the comment bubble when there are no pending comments.

Remove the drop down arrow which appears when hovering over the comments bubble admin menu item (requires pending comments to trigger in current trunk). Did this by only adding the sprite background to .menupop instead of all li.

Double checking CSS by somebody more familiar with the admin menu CSS (koop) is probably necessary.

@duck_4 years ago

comment:6 @duck_4 years ago

Refreshed tweaks post-[19152].

comment:7 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [19156]:

Tweaks for the admin bar comment bubble: allow JS updating the count, center the bubble when no pending comments, props duck_, fixes #18809

Note: See TracTickets for help on using tickets.