WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#18885 closed enhancement (fixed)

Use 'View Comment' instead of '#'

Reported by: zeo Owned by: chriscct7
Milestone: 4.4 Priority: normal
Severity: normal Version: 3.3
Component: Comments Keywords: has-patch has-screenshots
Focuses: Cc:

Description

Similar to #18846 but for Dashboard Recent Comments.

Feel free to refresh/tweak the patch if accepted.

Attachments (6)

18885.diff (2.7 KB) - added by zeo 8 years ago.
18885.2.diff (2.9 KB) - added by Zeo 8 years ago.
View Comment in the action links menu.
18885.patch (2.7 KB) - added by rachelbaker 4 years ago.
Screen Shot 2015-09-11 at 9.30.41 AM.png (134.4 KB) - added by ryan 4 years ago.
Before, Macnchrome, 4.3
IMG_4710.PNG (319.8 KB) - added by ryan 4 years ago.
After, iPhone 6+
IMG_3330.PNG (145.8 KB) - added by ryan 4 years ago.
After, iPhone 5

Download all attachments as: .zip

Change History (21)

@zeo
8 years ago

#1 @SergeyBiryukov
8 years ago

  • Milestone changed from Awaiting Review to 3.3

#2 @nacin
8 years ago

  • Type changed from task (blessed) to defect (bug)

#3 @ocean90
8 years ago

  • Keywords ui-feedback added

#4 @DrewAPicture
8 years ago

Use 'View Comment' instead of '#'

+1

#5 @jane
8 years ago

  • Keywords needs-refresh added; ui-feedback removed
  • Milestone changed from 3.3 to Future Release
  • Type changed from defect (bug) to enhancement

It would make more sense to either:
a) make it show the timestamp and link that, as it is on the comments screen, or
b) put View Comment in the action links menu.

Putting View Comment after the post/page name would be too awkward.

Also, this is an enhancement, not a bug. Therefore, punting because we are already long past the enhancement stage for 3.3.

@Zeo
8 years ago

View Comment in the action links menu.

#6 @Zeo
8 years ago

  • Keywords needs-refresh removed

New patch. View Comment in the action links menu. But if it going to be put there, wouldn't better using "View" instead of "View Comment".

#8 @sabreuse
6 years ago

  • Component changed from UI to Text Changes

#9 @chriscct7
4 years ago

  • Component changed from Text Changes to Comments
  • Keywords needs-refresh added
  • Milestone changed from Future Release to 4.4
  • Owner set to chriscct7
  • Status changed from new to assigned

@rachelbaker
4 years ago

#10 @rachelbaker
4 years ago

  • Keywords commit added; needs-refresh removed

In 18885.patch I refreshed the previous patch and only display the "View" link to approved comments.

Screenshot of the action links for an approved comment:
https://cldup.com/o8OEHMbkdd-600x600.png

Screenshot of the action links for an unapproved comment:
https://cldup.com/REF_CsLotb-600x600.png

#11 @rachelbaker
4 years ago

  • Keywords commit removed

#12 @wonderboymusic
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 34006:

Add a "View" row action for approved comments on the Dashboard screen, remove the link labeled #.

Props rachelbaker, zeo.
Fixes #18885.

#13 @ryan
4 years ago

  • Keywords needs-screenshots added

#14 @ryan
4 years ago

I'm going to add some before and after screenshots. I'm attempting before and after shots of all visual changes on multiple devices. Screenshots are used in visual changelogs and the Today in the Nightly posts, all of which increases awareness of our usability and make ui review easier. https://make.wordpress.org/core/tag/today-in-the-nightly/

If you'd like to help collect visuals, we want before and after screenshots on at least two devices, with one of them preferably being a phone. We're increasing our mobile/touch awareness by testing and capturing all visual changes from phones. Provide whatever screenshots you can. The Flow Patrol team will handle the remainder. Developers, taking screenshots of your patches and commits really helps ui/ux review and flow patrol. https://make.wordpress.org/flow/

Last edited 4 years ago by ryan (previous) (diff)

@ryan
4 years ago

Before, Macnchrome, 4.3

@ryan
4 years ago

After, iPhone 6+

@ryan
4 years ago

After, iPhone 5

#15 @ryan
4 years ago

  • Keywords has-screenshots added; needs-screenshots removed
Note: See TracTickets for help on using tickets.