WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#18889 closed enhancement (duplicate)

Add actions for menu items when editing in Admin

Reported by: andrei.igna Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Menus Keywords: has-patch
Focuses: Cc:

Description

Now the developers can't hook on menu items when editing menus in admin.

It would be good to add a few action in Walker_Nav_Menu_Edit (/wp-admin/includes/nav-menu.php line 85-125) so we can edit a menu item.

Attachments (1)

ticket18889.patch (2.3 KB) - added by andrei.igna 10 years ago.
updated wp from SVN, formatted the code

Download all attachments as: .zip

Change History (6)

#1 @andrei.igna
10 years ago

  • Keywords has-patch added; needs-patch removed

@andrei.igna
10 years ago

updated wp from SVN, formatted the code

#2 @andrei.igna
10 years ago

  • Version changed from 3.2.1 to 3.3

any chance for this to be added in WP 3.3? Would be awesome, we can do this for menus http://cl.ly/1T1I3Y2P283O0B2N2g19

#3 @duck_
10 years ago

This should be achievable currently by using a custom walker with the wp_edit_nav_menu_walker filter, see #13342 and [14645].

Though the downside compared to actions is that you cannot have multiple plugins adding extra inputs (unless they only filter for a specific menu ID [sidenote: maybe the wp_edit_nav_menu_walker could also supply the menu slug and/or name for added flexibility]).

As this is an enhancement I'm afraid that it will not make it into 3.3.

P.S. the version field marks the earliest version the bug has been found in and not the milestone it was/will be fixed in.

#4 @SergeyBiryukov
10 years ago

  • Version changed from 3.3 to 3.2.1

#5 @duck_
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14414.

Note: See TracTickets for help on using tickets.