WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#18891 closed defect (bug) (fixed)

wp_error does not recognize when a custom post type does not support excerpts

Reported by: ZaneMatthew Owned by:
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords: has-patch
Focuses: Cc:

Description

wp_error does not take into consideration if a custom post type does not support excerpts.

Steps to reproduce:

  1. Create a custom post type that does NOT support excerpts.
  2. Use wp_insert_post to insert the post
  3. print_r your error message and you'll see that wp_error is returns:

"Content, title, and excerpt are empty."

It should not mention excerpts being empty as the custom post type does not even support them.

Attachments (1)

18891.patch (1.0 KB) - added by SergeyBiryukov 4 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 @solarissmoke4 years ago

Is this a duplicate of #18713?

comment:2 @ZaneMatthew4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Yes it is, sorry.

comment:3 @SergeyBiryukov4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Related, but doesn't look like an exact duplicate to me.

#18713 is about wp_insert_post() bailing too early, while this ticket is about more correct error message.

Version 0, edited 4 years ago by SergeyBiryukov (next)

@SergeyBiryukov4 years ago

comment:4 @SergeyBiryukov4 years ago

  • Keywords has-patch added

comment:5 follow-up: @SergeyBiryukov3 years ago

  • Milestone changed from Awaiting Review to 3.3
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:6 in reply to: ↑ 5 ; follow-up: @johnbillion3 years ago

Replying to SergeyBiryukov:

[19305]

Doesn't this change mean that whole check now gets skipped if one or more of those fields aren't supported by the post type?

comment:7 in reply to: ↑ 6 @nacin3 years ago

Replying to johnbillion:

Replying to SergeyBiryukov:

[19305]

Doesn't this change mean that whole check now gets skipped if one or more of those fields aren't supported by the post type?

Yes. It basically means this check no longer applies to any customized post types.

Note: See TracTickets for help on using tickets.