WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18894 closed defect (bug) (fixed)

Don't show a view link for scheduled posts if user can't edit the post

Reported by: ocean90 Owned by: ryan
Milestone: 3.3 Priority: low
Severity: minor Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

User A(dmin) created a scheduled post.
Now user C(ontributer) can see in the all posts view the post which has an action link to view the post.
If he follow the link he ends in 404, because the post isn't public yet.

We should hide the link for the user C.

Attachments (1)

18894.patch (1.0 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (3)

ocean903 years ago

comment:1 DrewAPicture2 years ago

Reproduced the 404 on trunk, tested patch, works as expected.

Last edited 2 years ago by DrewAPicture (previous) (diff)

comment:2 ryan2 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [19213]:

Don't show the view link for a future post unless the current user has the permissions to edit the post. Treat future posts as a preview case. Props ocean90. fixes #18894

Note: See TracTickets for help on using tickets.