WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#18906 closed defect (bug) (fixed)

Admin fly-out menu are not working in RTL

Reported by: ramiy Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: major Version: 3.3
Component: Administration Keywords:
Focuses: Cc:

Description

wordpress for rtl sites (hebrew for me), is not working. tested on 2 sites. it doe's not show the submenu.

Attachments (1)

rtf-flyouts.png (33.7 KB) - added by azaozz 6 years ago.

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 3.3

#2 @walid3
6 years ago

I can confirm that too using Arabic install.

#3 @ramiy
6 years ago

and also, when i click on the collapse menu, it's not working.

#4 follow-up: @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18968]:

Menu RTL css refresh, fixes #18906

#5 in reply to: ↑ 4 @ramiy
6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

In [18968] you fixed the hovering problem, but the fly-out menus are still not visable.

@azaozz
6 years ago

#6 @azaozz
6 years ago

Which part of the flyouts?

http://core.trac.wordpress.org/raw-attachment/ticket/18906/rtf-flyouts.png

#7 @SergeyBiryukov
6 years ago

Was trying to keep RTL in sync in #18382, but due to the amount of intermediate changes, turned out it's better to wait for beta for final tweaking.

Checked current trunk with Hebrew language files in Firefox 7, Chrome 14, IE 8, Opera 11.51. Flyouts seem to be displayed correctly (as on the screenshot above).

#8 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

#9 @ramiy
6 years ago

re-tested, the fly-out's are working. and seems like the collapse problem was fixed.

#10 @ramiy
6 years ago

The "help" tab needs some rtl love.

#11 @svipic
6 years ago

@ramily I can see its working like a charm....

Note: See TracTickets for help on using tickets.