WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18911 closed defect (bug) (fixed)

some problems with the showcase page template

Reported by: walid3 Owned by: iandstewart
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

1- In the " latest posts " field of the showcase page, all the links after the first one lead to http://domainname.com/postname#respond
even if you are not hovering over the " leave reply " part, it just lead to this link no matter what, even the title go to responses.

2- the showcase featured posts section never follow the excerpt used in post by more tag, I don't want it to show anything of the post, just the main post image as I set my <--more--> tag after, and I don't want to make a featured image for that to work, just want my excerpt to be applied for it, I think that's more logic as it won't show parts of the post that user has hided already by more tag.

3 - the latest posts section is reversed from the whole blog layout, I mean the showcase sidebar show at the opposite position from normal sidebar position in categories and so, and that cause the latest post section to start from page center rather normal layout.

Attachments (1)

18911.patch (468 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 SergeyBiryukov3 years ago

  • Component changed from General to Bundled Theme

comment:2 walid32 years ago

Did someone else confirm that or it's a problem in my install only?

comment:3 SergeyBiryukov2 years ago

Can't reproduce point 1 in Firefox 7 or Chrome 14. Which browser are you using? Sounds like an unclosed tag somewhere, but I don't see any at a glance.

Confirmed point 2. "Continue reading" link is displayed in Twenty Eleven demo on WP.com, but not in the bundled theme.

Point 3 is also valid. Not sure if that's on purpose or not.

comment:4 knutsp2 years ago

  • Cc knut@… added

comment:5 follow-up: walid32 years ago

I just found that Point 1 is only in Arabic language website so i suppose it's a problem in rtl css.

SergeyBiryukov2 years ago

comment:6 in reply to: ↑ 5 SergeyBiryukov2 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.3

Replying to walid3:

I just found that Point 1 is only in Arabic language website so i suppose it's a problem in rtl css.

Confirmed. 18911.patch fixes that.

comment:7 nacin2 years ago

  • Owner set to iandstewart
  • Status changed from new to assigned

comment:8 iandstewart2 years ago

I can't reproduce point 1 in an RTL layout but the attached patch improves the RTL CSS and better matches the LTR styles. It looks good to me in that regard.

For point 2: The featured post area is intentionally limited in it's display -- using excerpts and featured images -- so the slideshow will work well with a wide amount of different types of posts. It would be cool and maybe more logical if the featured post grabbed the first large image in a post, looking for a more tag, and adjusting the layout, but it would indeed require more logic. :)

The effect described in point 3 is also intentional. The layout switches to invert the reading pattern of RTL languages, mirroring the default LTR pattern.

Version 0, edited 2 years ago by iandstewart (next)

comment:9 westi2 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In [19377]:

TwentyEleven: Improve RTL css to better match LTR experience. Fixes #18911 props SergeyBiryukov.

comment:10 WraithKenny2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#19344 is related to point 3, which doesn't seem to be intentional; It just doesn't respond to the theme setting as expected.

comment:11 iandstewart2 years ago

It's intentional that it doesn't respond to the theme layout setting. It's a separate custom template with it's own custom layout.

comment:12 nacin2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.