WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18967 closed defect (bug) (wontfix)

Network deactivating a plugin doesn't deactivate it on blogs where it was individually active

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Network Admin Keywords: 2nd-opinion dev-feedback
Focuses: multisite Cc:

Description

This one might need some concensus, but I the current behaviour isn't what I was expecting.

Steps to reproduce:

  1. Activate a plugin on an individual blog.
  2. Network activate the same plugin.
  3. Network de-activate the same plugin.
  4. Note that the plugin is still active on the individual blog despite the fact we've just network deactivated it.

I would expect network deactivating a plugin to deactivate it across the network regardless of its activation status on individual blogs.

Change History (5)

comment:1 johnbillion3 years ago

The reason this happens by the way is because the plugin remains in the active_plugins option on the individual blog.

comment:2 scribu3 years ago

If it was worded as "disable network activation", I believe you woudn't have this expectation.

There are benefits to both behaviours, yet it's easier to add the "deactivate on all individual blogs where it was activated" behaviour from a plugin than the other way around.

comment:3 scribu3 years ago

Or, if "network activate" was called instead "load this plugin on all blogs, regardless of it's activation state on individual blogs".

comment:4 scribu3 years ago

Finally, if we did this, to be consistent, when you network activate a plugin, we should also activate it individually on all blogs, correct?

comment:5 nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

During the merge this was confirmed as intended behavior.

Note: See TracTickets for help on using tickets.