Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#19034 closed enhancement (duplicate)

Select of type "multiple" is styled incorrect

Reported by: yo-l1982 Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.2.1
Component: Administration Keywords:
Focuses: Cc:


Adding a css selector in core admin-css to match a multiple select would be a nice feature, as for now the output of this will look like a input/text, and a user will have to add its own custom css-file just to style this type of select to make it usable.
Selects is styled generally and set to 2em height to match the most common select type.

Code that shows wrong.

<select multiple="multiple">

My suggestion to a solution is to add this into admin css:

#wpcontent select[multiple] {
   height: 4em;

Change History (3)

comment:1 @scribu4 years ago

Core uses checkbox lists instead of multiple selects. They're much more user friendly.

Maybe you should do the same.

comment:2 @scribu4 years ago

  • Component changed from General to Administration

comment:3 @scribu4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Also, duplicate of #10331

Note: See TracTickets for help on using tickets.