WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19042 closed defect (bug) (fixed)

RTL fixes for 3.3

Reported by: yoavf Owned by:
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: RTL Keywords:
Focuses: Cc:

Description (last modified by yoavf)

It's time for a main 3.3 RTL ticket - I know it's usually better to split things up (see {38} ) but I think that at this point it's better to consolidate issues so we can all work on this together.

The attached patch refreshes admin-bar-rtl completely to account for 3.3 changes, fixes a bug in the uploader RTL css, and with the admin footer.

The patch also consolidates fixes for:

Attachments (17)

3.3.rtl-1.patch (8.5 KB) - added by yoavf 2 years ago.
bubble.jpg (10.3 KB) - added by azaozz 2 years ago.
19042.help-and-screen-options.patch (3.9 KB) - added by SergeyBiryukov 2 years ago.
19042.toggle-arrow-cleanup.patch (1.6 KB) - added by SergeyBiryukov 2 years ago.
19042.welcome-panel.patch (1.3 KB) - added by SergeyBiryukov 2 years ago.
19042.plugin-update-message.diff (463 bytes) - added by rosshanney 2 years ago.
plugin-update-message.png (7.9 KB) - added by rosshanney 2 years ago.
19042.collapse-icon-and-submenu-shadows.diff (1.5 KB) - added by rosshanney 2 years ago.
collapse-icon-and-submenu-shadows.png (8.3 KB) - added by rosshanney 2 years ago.
19042.admin-bar-howdy-menu.diff (1.4 KB) - added by rosshanney 2 years ago.
admin-bar-howdy-menu.png (2.7 KB) - added by rosshanney 2 years ago.
19042.admin-bar-howdy-menu-2.diff (1.4 KB) - added by rosshanney 2 years ago.
Update for "Howdy" menu patch, after [19261] changes.
19042.admin-bar-howdy-menu-3.diff (1.5 KB) - added by rosshanney 2 years ago.
Another update for "Howdy" patch, after [19270].
19042.flyoutjump.diff (389 bytes) - added by helenyhou 2 years ago.
Fix for flyout jumpiness
plugin-deactivated-bad-period.png (180.7 KB) - added by georgestephanis 2 years ago.
When deactivating a plugin (and I'm not sure where else) the text alert reads .Plugin deactivated (sic)
admin-menu-rtl.patch (7.3 KB) - added by ocean90 2 years ago.
19042.helptabs.diff (786 bytes) - added by helenyhou 2 years ago.
Help tab

Download all attachments as: .zip

Change History (47)

yoavf2 years ago

comment:1 yoavf2 years ago

  • Description modified (diff)

comment:2 azaozz2 years ago

In [19080]:

RTL fixes for 3.3, props yoavf SergeyBiryukov rosshanney, see #19042 fixes #18000, fixes #17988, fixes #19006

comment:3 follow-up: rosshanney2 years ago

I've noticed a few RTL issues with the admin bar in Internet Explorer. For example, in IE9, the white update count circle doesn't appear correctly and the little downward pointing arrows don't appear at all (or appear in the wrong place with the patch proposed in #19086).

Also, in IE7, everything in the admin bar disappears altogether on hover.

Is it best to create separate tickets for these issues, or just discuss them here?

azaozz2 years ago

comment:4 in reply to: ↑ 3 ; follow-up: azaozz2 years ago

Replying to rosshanney:

The bubble looks fine to me:


and the arrows are most likely going to be removed (they were meant to appear on hover if the menus needed clicks to open).

Last edited 2 years ago by azaozz (previous) (diff)

comment:5 in reply to: ↑ 4 rosshanney2 years ago

I'm referring to the available update count notification (the white circle), not the comments bubble.

Replying to azaozz:

and the arrows are most likely going to be removed (they were meant to appear on hover if the menus needed clicks to open).

Ah, I see. Fair enough!

comment:6 SergeyBiryukov2 years ago

19042.help-and-screen-options.patch contains RTL adjustments for Help and Screen options since [19131].

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

comment:7 follow-up: SergeyBiryukov2 years ago

19042.toggle-arrow-cleanup.patch cleans up unused .toggle-arrow class styles.

Being in RTL sections of colors-*.css files, they:

  1. Don't have .rtl prefix.
  2. Are overridden by editor-buttons.css.

comment:8 in reply to: ↑ 7 azaozz2 years ago

Replying to SergeyBiryukov:

  1. Are overridden by editor-buttons.css.

Editor-buttons is supposed to hold all styling for outside the editors (mostly buttons and toolbars) as they can be used on the front end now. For the blue theme and specific RTL for the admin we could use a bit more specific selectors, i.e. prefix the selectors by one of the container classes/IDs like #wpcontent, #wpbody, .wrap, etc. as editor-buttons.css is loaded after the RTL stylesheets (mid-page).

Last edited 2 years ago by azaozz (previous) (diff)

comment:9 azaozz2 years ago

In [19147]:

Help and Screen Options RTL adjustments, props SergeyBiryukov, see #19042

comment:10 azaozz2 years ago

In [19148]:

Remove unused .toggle-arrow styling, props SergeyBiryukov, see #19042

comment:11 SergeyBiryukov2 years ago

19042.welcome-panel.patch contains RTL adjustments for Welcome Panel as per [19163].

comment:12 rosshanney2 years ago

The plugin update message on the plugins screen is a little out of place.


Please see 19042.plugin-update-message.diff.

Last edited 2 years ago by rosshanney (previous) (diff)

comment:13 rosshanney2 years ago

The collapse icon points the wrong way when the admin menu is collapsed (.folded). Also, the shadows on admin menu flyouts don't seem quite right.


Please see 19042.collapse-icon-and-submenu-shadows.diff

comment:14 rosshanney2 years ago

The "Howdy" section of the admin bar no longer appears at the far left. I think caused by [19230].


Please see 19042.admin-bar-howdy-menu.diff

rosshanney2 years ago

Update for "Howdy" menu patch, after [19261] changes.

rosshanney2 years ago

Another update for "Howdy" patch, after [19270].

comment:15 azaozz2 years ago

In [19307]:

More RTL fixes, props rosshanney, see #19042

helenyhou2 years ago

Fix for flyout jumpiness

comment:16 helenyhou2 years ago

Submenu flyout jumps on focus: http://cl.ly/0v0a3C1v1M3d3z0E3w1Y

19042.flyoutjump.diff should fix it.

georgestephanis2 years ago

When deactivating a plugin (and I'm not sure where else) the text alert reads .Plugin deactivated (sic)

comment:17 georgestephanis2 years ago

Ignore my last bug report-image, I'm an idiot newb to RTL.

comment:18 georgestephanis2 years ago

That being said, my latest patch on #18654 -- 18654.with-201-percent-more-rtl.diff -- also happens to fix the user menu in RTL. I'm cross-posting so it doesn't get lost in the shuffle somehow (thanks, jjj!)

comment:19 ocean902 years ago

  • Priority changed from normal to high
  • Severity changed from normal to major

Admin bar needs some RTL love.

http://cl.ly/BvCC/Bildschirmfoto%202011-11-18%20um%2013.24.03.png

Last edited 2 years ago by ocean90 (previous) (diff)

ocean902 years ago

comment:21 ocean902 years ago

admin-menu-rtl.patch will fix all RTL issues with the admin menu, includes the issue mentioned by helenyhou in comment:16.

comment:22 azaozz2 years ago

In [19353]:

More RTL for the admin menu, props ocean90, see#19042

comment:23 ocean902 years ago

  • Keywords needs-patch added; has-patch removed
  • Priority changed from high to normal
  • Severity changed from major to normal

http://cl.ly/ByjA/Bildschirmfoto%202011-11-19%20um%2018.52.30.png

The progress bar shows a dark line at beginning. Only in thickbox media uploader.

comment:24 azaozz2 years ago

In [19360]:

Remove old styling for rtl progress bar, see #19042

comment:25 helenyhou2 years ago

Help styling is broken: http://cl.ly/2C331K2P2t2M0C0q2K0n

Working on a patch.

helenyhou2 years ago

Help tab

comment:26 helenyhou2 years ago

19042.helptabs.diff fixes help styling, probably broken in r19361.

comment:27 azaozz2 years ago

In [19371]:

Help tabs RTL fixes, props helenyhou, see #19042

comment:28 ocean902 years ago

  • Keywords needs-patch removed

Please open new tickets for still existing RTL issues.

comment:29 ocean902 years ago

  • Resolution set to fixed
  • Status changed from new to closed

comment:30 azaozz2 years ago

In [19446]:

Few more RTL and IE7 fixes, see #19042

Note: See TracTickets for help on using tickets.