WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 8 months ago

Last modified 8 months ago

#19044 closed defect (bug) (worksforme)

$depth in start_el Walker_Category has null value

Reported by: nukecpower Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords: reporter-feedback
Focuses: Cc:

Description

File wp-includes/category-template.php
Line: 829

Issue:

The variable $depth is not returning value.
start_el() - $depth not showing. (Always return zero)
start_lvl() - $depth works fine. 
end_lvl() - $depth works fine.
/**
	 * @see Walker::start_el()
	 * @since 2.1.0
	 *
	 * @param string $output Passed by reference. Used to append additional content.
	 * @param object $category Category data object.
	 * @param int $depth Depth of category in reference to parents.
	 * @param array $args
	 */
	function start_el(&$output, $category, $depth, $args) {
.....

Change History (4)

comment:1 SergeyBiryukov2 years ago

  • Keywords reporter-feedback added

Could you please add the steps to reproduce? Not sure I understand the problem.

comment:2 avryl8 months ago

  • Resolution set to invalid
  • Status changed from new to closed

No reporter feedback in almost two years.

comment:3 ocean908 months ago

  • Milestone Awaiting Review deleted

comment:4 SergeyBiryukov8 months ago

  • Resolution changed from invalid to worksforme
Note: See TracTickets for help on using tickets.