WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19048 closed enhancement (duplicate)

Allow for Term Metas

Reported by: scottconnerly Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Taxonomy Keywords: needs-patch
Focuses: Cc:

Description

Create the table termmeta akin to postmeta
Add the $wbdb member $table 'termmeta'

Filters already exist in wp_update_term and wp_insert_term that allow developers to write to these tables. Actions already exist in edit-tags.php and edit-tag-form.php that allow the fields to be added.

Use case:
I'm building a shopping cart on WP. Products get assigned taxonomies. Those taxonomies have info on how the products should be handled in the shopping cart.

Change History (3)

comment:1 knutsp2 years ago

  • Cc knut@… added

I like this. Name the table taxonomymeta.

But this is probably a duplicate or wontfix. The reason usually spoken is that a taxonomy is not supposed to hold any data. A taxonomy is about grouping of data. Even though we have a description field for each term. Both a name field and a description field holds data. We are not talking about an index in a database table.

From the movie Apollo 13 (1995): Gene Kranz: I don't care about what anything was DESIGNED to do, I care about what it CAN do.

Many plugins offering custom taxonomies create either a taxonomyfields or taxonomymeta table. This table layout should be standardized so that the data may be shared by different plugins offering such metadata to be stored.

comment:2 nacin2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

taxonomymeta seems to indicate meta about a taxonomy. termmeta indicates meta about a term. Actually what you'd be looking for is term_taxonomymeta, meta about a term for a specific taxonomy. Thanks to the complexities of our term/taxonomy schema and API, this becomes convoluted quickly.

Closing as a duplicate of #10142. See comment 50 from me. For further thoughts, see #17477, comment 1 from me.

comment:3 knutsp2 years ago

We don't really need any core functions to support this, even if that would be nice. It's about the table beeing standardized as a core table. This is just like the post format taxonomy, being offered to theme authors. A term_taxonomymeta table is an offer to plugin authors.

The situation out there in the wild is a mess. This is something that than core can do something about. In the meantime the problem grows. Where did the philosophy behind post formats go?

Note: See TracTickets for help on using tickets.