Make WordPress Core

Opened 13 years ago

Closed 12 years ago

Last modified 7 years ago

#19060 closed defect (bug) (duplicate)

admin CSS: .code, code should have direction:ltr (for rtl installations)

Reported by: panuy's profile panuy Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: RTL Keywords: has-patch
Focuses: Cc:

Description

selectors .code, code indicate code, which is 100% of the times english text that must be aligned to the left, and have left-to-right directionality.

if the administration panel is in RTL mode, the code textboxes are reversed, and it is nearly impossible to edit them.

the suggested code will not affect LTR installations.

suggested fix at wp-admin-rtl.dev.css file:

.code, code {

direction: ltr;
(...)

}

Attachments (1)

19060.patch (285 bytes) - added by ramiy 12 years ago.

Download all attachments as: .zip

Change History (13)

#1 @ocean90
13 years ago

  • Keywords rtl-feedback needs-patch added; has-patch needs-testing removed

#2 @ramiy
12 years ago

I agree, this is a very good idea. <code> tag has no rtl text, so it has to have left-to-right direction.

#3 @ramiy
12 years ago

Related: #18021

#4 @nacin
12 years ago

  • Keywords rtl-feedback removed

Patch?

@ramiy
12 years ago

#5 @ramiy
12 years ago

  • Keywords has-patch added; needs-patch removed

#6 @ramiy
12 years ago

see also - #16834

#7 follow-up: @azaozz
12 years ago

So, what's the best way for here: unicode-bidi: override; or direction: ltr;?

#9 @nacin
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #19598.

This ticket was mentioned in Slack in #polyglots by sergey. View the logs.


7 years ago

This ticket was mentioned in Slack in #core-i18n by sergey. View the logs.


7 years ago

#12 in reply to: ↑ 7 @ramiy
7 years ago

Replying to azaozz:

So, what's the best way for here: unicode-bidi: override; or direction: ltr;?

With direction the entire block is displayed from left to right. With unicode-bidi you use it when the text has several languages.

For example when a text has both English and Hebrew we need to use unicode-bidi to fix visual issues. But code blocks has only English text, so we need to set only the direction.

Note: See TracTickets for help on using tickets.