WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#19096 closed defect (bug) (fixed)

Blogger Importer fails after 20 items, then sticks at "Set Authors"

Reported by: yorksranter Owned by:
Milestone: WordPress.org Priority: normal
Severity: major Version: 3.2.1
Component: Import Keywords: dev-feedback needs-patch
Focuses: Cc:

Description

Using the OAuth branch version of the Blogger Importer plugin (http://plugins.svn.wordpress.org/blogger-importer/branches/oauth/ - tickets #14525 and #15290 refer), the OAuth handshake occurs correctly and 20 or so items are imported. This may or may not require hitting "continue".

The plugin in then asks to "set authors". Once the user mapping is set, any attempt to import more posts fails as the plugin remains in the "set authors" state.

We have now reached the marker of 12 months since I initially reported the bug in #14525 and this is a *bit* of a wait for an import.

Change History (6)

comment:1 SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to WordPress.org

comment:2 follow-up: yorksranter2 years ago

  • Version changed from 3.2.1 to 3.3.1

Still broken in 3.3.1, in the same way. Possible to import 13 posts, then clear all data, then start again.

New "clean-blogger-importer" doesn't work at all, old getaddrinfo() error back.

comment:3 SergeyBiryukov2 years ago

  • Version changed from 3.3.1 to 3.2.1

Version number indicates when the bug was initially introduced/reported. That said, since the import code actually resides in the Blogger Importer plugin, the core version shouldn't affect how it works.

comment:4 in reply to: ↑ 2 Workshopshed2 years ago

Replying to yorksranter:

Still broken in 3.3.1, in the same way. Possible to import 13 posts, then clear all data, then start again.

New "clean-blogger-importer" doesn't work at all, old getaddrinfo() error back.

The "new" clean-blogger-importer is just a fork of the old importer with some code to filter messages, it's not the created by the core team so issues with that don't get reported here but against that plugin.

comment:5 Workshopshed2 years ago

I tried to reproduce this issue on a smaller data set by setting 'MAX_RESULTS' to a smaller value, seems to be intermittant. Perhaps the timeout instead?

Last edited 2 years ago by Workshopshed (previous) (diff)

comment:6 Otto4222 months ago

  • Resolution set to fixed
  • Status changed from new to closed

New blogger importer code has been pushed into 0.5 with a slew of new fixes. If this can still be reproduced, re-open this ticket.

Note: See TracTickets for help on using tickets.