WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#19101 closed defect (bug) (duplicate)

Several E_STRICT php errors when comparing post versions

Reported by: arena Owned by: arena
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: External Libraries Keywords: 2nd-opinion
Focuses: Cc:

Description

Several E_STRICT php errors when comparing post versions

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff.php at line 380

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff.php at line 402

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff.php at line 424

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff.php at line 446

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff\Renderer.php at line 101

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff\Renderer.php at line 121

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff\Engine\native.php at line 107

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in wp-includes\Text\Diff\Engine\native.php at line 122

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in D:\webserver\htdocs\wordpress\wp-includes\Text\Diff\Engine\native.php at line 124

[E_STRICT] 2048 : Assigning the return value of new by reference is deprecated in D:\webserver\htdocs\wordpress\wp-includes\Text\Diff\Engine\native.php at line 126

[E_STRICT] 2048 : Non-static method Text_Diff::trimNewlines() cannot be called statically in wp-includes\Text\Diff\Engine\native.php at line 33

[E_STRICT] 2048 : Non-static method Text_Diff::trimNewlines() cannot be called statically in wp-includes\Text\Diff\Engine\native.php at line 34

Change History (1)

comment:1 @nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12367.

Note: See TracTickets for help on using tickets.