WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19105 closed defect (bug) (fixed)

Spell check suggestions offset vertically when page is scrolled

Reported by: JPry Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: TinyMCE Keywords: dev-feedback
Focuses: Cc:

Description

When the Spell Check feature of TinyMCE is activated, and the current page is scrolled down, the pop-up box that displays the spelling suggestions is moved UP in proportion to how far down the page is scrolled. This could potentially lead to the spelling suggestions being displayed above the browser view, making it seem as if this functionality is not working at all.

I have found this to be reproducible on the following browsers: IE 9.0.3, Firefox 7.0.1, Safari 5.1.1 on Windows 7, and Firefox 7.0.1 on Linux Mint (Ubuntu based). This occurs with no active plugins, and when using the Twenty Eleven theme, so I do not believe it is caused by a plugin or theme.

Change History (12)

comment:1 azaozz2 years ago

This should be fixed upstream by the TinyMCE developers, don't think there's anything we can do about it.

comment:2 follow-up: solarissmoke2 years ago

There's a bug report and proposed fix upstream.

comment:3 in reply to: ↑ 2 JPry2 years ago

Replying to solarissmoke:

There's a bug report and proposed fix upstream.

It looks like this was from back in April 2011. I admit that I am not terribly familiar with the guts of TinyMCE, so if the answer to this question is easily found, please forgive me: What version of TinyMCE is WordPress using?

I am also seeing that the proposed fix you mention seems to have not been implemented yet (as best as I can tell) in the TinyMCE master branch on GitHub. Is anyone familiar enough with submitting fixes to TinyMCE to submit that fix to them?

comment:4 follow-up: JPry2 years ago

Ok, I seemed to have answered part of my own question. After some more digging, I found that this was fixed as of version 2.0.6: http://www.tinymce.com/develop/bugtracker_view.php?id=4554.

Again, being unfamiliar with TinyMCE, is it possible to just update to this version in the WordPress core?

Last edited 2 years ago by JPry (previous) (diff)

comment:5 in reply to: ↑ 4 azaozz2 years ago

  • Keywords reporter-feedback added
  • Owner set to azaozz
  • Status changed from new to reviewing

Replying to JPry:

Yes, there is a newer release of the spellchecker plugin for TinyMCE (2.0.6) where that is fixed. It's a bit late for updated external libraries but since this is only a plugin with seemingly minimal changes, perhaps we can test it fast and include it in 3.3.

Help with testing is always appreciated :)

Last edited 2 years ago by azaozz (previous) (diff)

comment:6 follow-up: JPry2 years ago

I'd be happy to help test once TinyMCE has been updated. I originally found this problem because this is a feature that I would like to have working properly for a project I'm working on.

comment:7 in reply to: ↑ 6 azaozz2 years ago

Replying to JPry:

For testing you can download version 2.0.6 of the spellchecker plugin and replace the old one in wp-includes/js/tinymce/plugins on a test install (I'll be doing that too). Then have a look in as many different browsers as you can to confirm all is working okay.

comment:8 JPry2 years ago

I've done what you said, and I can confirm that it's working correctly in IE, Firefox and Safari (the same versions I mentioned before).

comment:9 follow-up: JPry2 years ago

  • Keywords dev-feedback added; reporter-feedback removed

Is there anything else you'd like me to do as far as testing or confirmation that this seems to be working? Is there any chance that it will be able to make it into the 3.3 version when it's released?

comment:10 in reply to: ↑ 9 azaozz2 years ago

Replying to JPry:

Thanks for the testing. It seems to pass the tests here too so thinking to adding it today.

comment:11 azaozz2 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In [19178]:

Update the spellchecker plugin for TinyMCE to 2.0.6, fixes #19105

comment:12 SergeyBiryukov2 years ago

  • Milestone changed from Awaiting Review to 3.3
Note: See TracTickets for help on using tickets.