WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#19149 closed defect (bug) (fixed)

Text entered in Admin Bar Search cannot be selected

Reported by: SergeyBiryukov Owned by: koopersmith
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Toolbar Keywords:
Focuses: Cc:

Description

Once some text is typed into Admin Bar Search, it cannot be selected with a mouse (to copy, etc.), only from keyboard.

Tested in Firefox 7.01, Chrome 15, IE 8.

In Opera 11.52, the text can't even be entered there.

Change History (8)

comment:1 follow-up: ocean903 years ago

For me it works in Chrome 16 and Opera 11.52. Can only reproduce it in Firefox.

If I remove href="#" from the link around the form it works.

To test: http://jsfiddle.net/5LeGL/

Last edited 3 years ago by ocean90 (previous) (diff)

comment:2 in reply to: ↑ 1 SergeyBiryukov3 years ago

Replying to ocean90:

For me it works in Chrome 16 and Opera 11.52.

Yeah, selection in Opera is possible since [19157]. But an attempt to copy the selected text would only provide an option to copy the underlying link instead.

Version 0, edited 3 years ago by SergeyBiryukov (next)

comment:3 toscho3 years ago

  • Cc info@… added

Why is the dead link around the form there? I don’t see the benefit for the user anyway.

comment:4 ocean903 years ago

toscho, because of the API.

Related: #15519

comment:5 toscho3 years ago

Hm, too bad. The first time I clicked on this link I wondered if something was broken. Now I know it. :)
Those links are confusing, take more time to tab through, and they have strange side effect, as we can see here.

One more thing: Browsers offer different context menus depending on the focus. In Opera one cannot insert predefined information (name, phone number, notices) in a linked form element now. So this issue is not just about selecting text.

comment:6 ryan3 years ago

  • Component changed from UI to Admin Bar

comment:7 ryan3 years ago

See also #19151

comment:8 koopersmith3 years ago

  • Owner set to koopersmith
  • Resolution set to fixed
  • Status changed from new to closed

In [19328]:

Allow linkless items in the admin bar. Improve non-jQuery admin bar tabbing. fixes #19277, #19149, #19164, #15519. see #18197, #19088.

Note: See TracTickets for help on using tickets.