WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 20 months ago

#19158 closed enhancement (worksforme)

Fix list numbering on Freedoms admin screen

Reported by: kpdesign Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Administration Keywords: has-patch ui-feedback close
Focuses: Cc:

Description

The list of 4 freedoms on the Freedoms screen begins with 0, not 1. Issue has existed since that admin screen was introduced in 3.2.

Attached patch fixes Jane's request on original ticket (#17383) to update the original <ol start="0"> code.

Also added "since x.x" to PHPDoc block.

Attachments (3)

wp3.3-list-numbering-issue.png (7.9 KB) - added by kpdesign 3 years ago.
freedoms-list-issue.patch (1.1 KB) - added by kpdesign 3 years ago.
19158.patch (2.1 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (13)

@SergeyBiryukov3 years ago

comment:1 follow-up: @SergeyBiryukov3 years ago

I thought starting from 0 was deliberate, and Jane's suggestion was about replacing the deprecated start attribute with CSS. 19158.patch is an attempt to do this.

comment:2 in reply to: ↑ 1 ; follow-up: @kpdesign3 years ago

Replying to SergeyBiryukov:

I thought starting from 0 was deliberate, and Jane's suggestion was about replacing the deprecated start attribute with CSS. 19158.patch is an attempt to do this.

Why would you start numbering a list with a zero?

comment:3 @SergeyBiryukov3 years ago

  • Keywords ui-feedback added

comment:4 in reply to: ↑ 2 @duck_3 years ago

Replying to kpdesign:

Why would you start numbering a list with a zero?

Because the FSF defines the four freedoms that constitute free software as "freedom 0" through "freedom 3", see What is free software?. I assume it starts at 0 because that's where computers start counting from, e.g. the first index of an array in most languages is 0.

comment:5 @nacin3 years ago

  • Keywords close added

I'm pretty sure that the start attribute is no longer deprecated in HTML5.

comment:7 @nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

comment:8 @jane3 years ago

  • Type changed from defect (bug) to enhancement

It starts with 0 intentionally, because that is how FSF does it,. As we are liberally quoting them, we are following their system (even though Americans usually don't start from 0 in lists or apartment floors). We absolutely cannot change this to start from 1, and it's not a bug.

comment:9 @helen2 years ago

#22969 was marked as a duplicate.

comment:10 @SergeyBiryukov20 months ago

#22969 was marked as a duplicate.

Note: See TracTickets for help on using tickets.