WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19174 closed defect (bug) (fixed)

Scaling prompt below uploader

Reported by: jane Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Media Keywords:
Focuses: Cc:

Description

In the uploader window, it says:
"Scale images to match the large size selected in image options (1024 × 1024)."

While many people upload giant iPhone or camera images that could benefit from being scaled down automatically, even more upload images that are nowhere near that big. This line suggests smaller images will be scaled up in that case, which is not good.

  1. Is it going to scale things up as well?
  1. Is it scaling down and only uploading the scaled down version, or is it still uploading the full size? If someone chooses Link to: Original file, would they link to the 'large size' or the original size?

Am concerned about this feature being confusing.

Attachments (1)

19174.patch (1.2 KB) - added by DrewAPicture 2 years ago.
Here's a patch based on azaozz's suggested wording

Download all attachments as: .zip

Change History (18)

comment:1 johnbillion2 years ago

+1. It's not at all clear what this option does.

comment:2 DrewAPicture2 years ago

What about something like this:

[] Scale down images with dimensions larger than 1024 x 1024 (the large size selected in image options).

Also, I remember there being brief discussion about a shorter label followed by more of a description. An example:

[] Scale down large images

Images with dimensions higher than the large size selected in image options (1024 x 1024) will be proportionally resized to fit.

Or something.

comment:3 in reply to: ↑ description azaozz2 years ago

Replying to jane:

  1. Is it going to scale things up as well?

No.

  1. Is it scaling down and only uploading the scaled down version, or is it still uploading the full size? If someone chooses Link to: Original file, would they link to the 'large size' or the original size?

This depends on the uploader runtime and browser used. HTML5 (the default runtime) would scale the images before uploading in FF and Chrome but not in Opera or Safari. Silverlight or Flash (used in IE) will scale before uploading: http://www.plupload.com/

Perhaps something like the second option suggested by @DrewAPicture would be better:

[] Scale down large images

Images will be proportionally resized to the large size selected in
<a>image options</a> (1024 x 1024) if they are bigger. 
Last edited 2 years ago by azaozz (previous) (diff)

DrewAPicture2 years ago

Here's a patch based on azaozz's suggested wording

comment:4 DrewAPicture2 years ago

  • Cc xoodrew@… added

comment:5 follow-up: jane2 years ago

If the action is not consistent between browsers, I'm uncomfortable with making any statement about what's happening, unless we're sniffing and showing specific message (which seems excessive for something people may or may not even want to use. Wondering if we should pull the auto-scale out altogether and make it a plugin.

comment:6 SergeyBiryukov2 years ago

FWIW, there was a relevant IRC discussion in October.

comment:7 in reply to: ↑ 5 DrewAPicture2 years ago

Replying to jane:

If the action is not consistent between browsers, I'm uncomfortable with making any statement about what's happening, unless we're sniffing and showing specific message (which seems excessive for something people may or may not even want to use. Wondering if we should pull the auto-scale out altogether and make it a plugin.

On the one hand, I see this as very valid functionality. I manually re-scaled images on a newspaper website the other week for 2 years worth of uploads and dropped the filesizes by 75 percent. So having this at the outset would provide a certain performance upgrade.

On the other hand, since it's not consistent cross-browser, I do see the value in browser sniffing to display or not display, but I agree that it seems a bit "excessive" for something to include in core. Maybe pushing out to a separate plugin would be a good idea.

Last edited 2 years ago by DrewAPicture (previous) (diff)

comment:8 ryan2 years ago

Per bug scrub, we'll remove this from 3.3, make it a plugin, and look at it again in 3.4.

comment:9 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [19223]:

Remove the Resize files checkbox for now (revisit in 3.4), fixes #19174

comment:10 follow-ups: nacin2 years ago

What if we left all of [19223] but just removed the hook? Makes it a heck of a lot easier for a plugin to implement it in all it's half-baked glory.

comment:11 in reply to: ↑ 10 azaozz2 years ago

Replying to nacin:

Makes sense, will revert in a min.

comment:12 in reply to: ↑ 10 DrewAPicture2 years ago

Replying to nacin:

What if we left all of [19223] but just removed the hook? Makes it a heck of a lot easier for a plugin to implement it in all it's half-baked glory.

+1

comment:13 azaozz2 years ago

In [19225]:

Revert [19223] and only stop showing the checkbox, props nacin, see #19174

comment:14 azaozz2 years ago

In [19226]:

Revert media.php too, see #19174

comment:15 uggbootsspace2 years ago

Nothing.

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

comment:16 follow-up: jayarjo2 years ago

  • Cc jayarjo added

I can help to overcome inconsistencies here, if any. But I'm not sure what the requirements for client-side image resizing should be. Is it meant to upsize too?

Having certain combination of options and narrowing runtime choice to HTML5, Flash and SilverLight only (other runtimes cannot scale images and/or retain EXIF information #14459), it can be made to operate consistently across vast majority of available platforms (if you could name problematic ones I could take care of them too).

comment:17 in reply to: ↑ 16 DrewAPicture2 years ago

Replying to jayarjo:

Is it meant to upsize too?

I hope not, scaling images up generally doesn't produce the best results just as attempting to make standard def video magically into high def video doesn't really work out.

it can be made to operate consistently across vast majority of available platforms

I think we'll just have to test to see which browsers/platform work and which don't then allow/disallow based on that. But as Jane said before, the labeling that goes with this would need to change depending on the expected behavior of those browsers/platforms.

Note: See TracTickets for help on using tickets.