WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#19190 closed defect (bug) (worksforme)

Uploader and Admin bar conflict in IE9

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Upload Keywords: reporter-feedback needs-testing
Focuses: Cc:

Description

Go to menu Media - Upload.

Admin bar is partly missing background (see attached screenshot).

Hovering over it with mouse cursor or clicking somewhere - background is back.

Latest trunk, IE9.

Attachments (3)

Uploading_media.png (20.3 KB) - added by pavelevap 4 years ago.
19190.admin-bar-ie9.png (27.5 KB) - added by SergeyBiryukov 4 years ago.
Save_all_Changes_button.png (15.5 KB) - added by pavelevap 4 years ago.

Download all attachments as: .zip

Change History (18)

@pavelevap4 years ago

comment:1 @SergeyBiryukov4 years ago

  • Milestone changed from Awaiting Review to 3.3

comment:2 @SergeyBiryukov4 years ago

Hmm, cannot reproduce in latest trunk with IE 8 or IE 9.

comment:3 @nacin4 years ago

  • Milestone 3.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

ocean90 also cannot reproduce this.

Please re-open if it is reproducible with no plugins and the default theme. Then try switching to en_US, as it may be an issue somewhere with an HTML tag in a translation or something.

comment:4 @pavelevap4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I tried to find the cause of this problem and it is probably related to Microsoft Silverlight extension in IE9. After deactivating this extension, problem disappears. After reactivating this extension is problem back. Also when I switch to browser uploader, problem disappears (not dependent on Silverlight).

I noticed also another small glitch: When loading "Add New" page for Media, for a little moment there is grey button "Save all Changes" bellow. Everytime I referesh this page, this button appears for a second and then disappears. See attached screenshot.

comment:5 @SergeyBiryukov4 years ago

  • Milestone set to 3.3

comment:6 @azaozz4 years ago

In [19306]:

Make the Save All Changes initially hidden on Media -> Add New screen, improve the progress bar "progress" to 1px ticks, see #19190

comment:7 @azaozz4 years ago

  • Milestone 3.3 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Don't see this in current trunk, feel free to reopen if it still conflicts.

comment:8 follow-up: @pavelevap4 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Great, "Save all Changes" button disappeared. But first part of the problem persists for my local install. It is probably some strange conflict with Microsoft Silverlight, I can not see it everytime, but usually after refresh (CTRL + F5 or CTRL + R) problem with admin bar appears... I am not sure how and what to debug to get additional info. Using latest trunk, Twenty Eleven, EN version, IE9, Windows Vista...

comment:9 @SergeyBiryukov4 years ago

  • Milestone set to Awaiting Review

comment:10 @kurtpayne4 years ago

  • Cc kpayne@… added

I cannot reproduce the original problem (admin bar display issues). I've tested with IE7, IE8, IE9 with Silverlight both enabled and disabled but I cannot reproduce Uploading_media.png.

Replying to pavelevap:

I noticed also another small glitch: When loading "Add New" page for Media, for a little moment there is grey button "Save all Changes" bellow. Everytime I referesh this page, this button appears for a second and then disappears. See attached screenshot.

I can reproduce this in IE7, IE8, and IE9. Screen cap at: http://kpayne.co/trac/19190.html

This is coming from handlers.dev.js. When the DOM is loaded, updateMediaForm() is called and .savebutton is hidden if there are no files in the list.

comment:11 @nacin4 years ago

  • Milestone changed from Awaiting Review to 3.3

comment:12 in reply to: ↑ 8 @azaozz4 years ago

Replying to pavelevap:

I can't reproduce the admin bar problem in IE either. Tried with and without silverlight on win7-64. BTW is that the 32 or 64 bits IE?

Last edited 4 years ago by azaozz (previous) (diff)

comment:13 @azaozz4 years ago

  • Keywords reporter-feedback needs_testing added

comment:14 @SergeyBiryukov4 years ago

  • Keywords needs-testing added; needs_testing removed

comment:15 @azaozz4 years ago

  • Milestone 3.3 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Couldn't reproduce this before, still can't reproduce this as of [19367]. If this still happens please reopen with exact instructions how to reproduce and/or conditions when that happens.

Note: See TracTickets for help on using tickets.