WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19191 closed defect (bug) (fixed)

Improve admin menu tab navigation

Reported by: koopersmith Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

Currently, there are no visual indicators when when an admin menu item is focused using the tab key. We should add visual feedback when an item is focused and expand the submenus to allow users to access submenu items via tabbing.

Attachments (1)

19191.diff (2.8 KB) - added by johnkleinschmidt 2 years ago.
Better patch that fixes tabbing through menus a second time

Download all attachments as: .zip

Change History (11)

comment:1 koopersmith2 years ago

In [19198]:

Improve admin menu tab navigation for expanded menus. Folded menus require a few markup improvements. see #19191.

comment:2 jane2 years ago

Why was this ticket opened instead of using #19088?

comment:3 ocean902 years ago

jane, this is for the admin menu and #19088 for the admin bar. I think.

comment:4 nacin2 years ago

  • Milestone changed from Awaiting Review to 3.3

comment:5 johnkleinschmidt2 years ago

  • Cc johnkleinschmidt added
  • Keywords has-patch needs-testing added

johnkleinschmidt2 years ago

Better patch that fixes tabbing through menus a second time

comment:6 johnkleinschmidt2 years ago

My original patch did display the visual feedback when an item is focused and expanded the submenus and allowed tabbing through them, but I noticed that if you kept on tabbing eventually you would get to the menus a second time, but they would not expand/navigate properly. This was due to the fact that the wp-menu-image links did not have a tabindex on them and therefore were last in the tabbing order. If these links are assigned a positive value tabindex, it messes up the tabbed navigation because you would have to tab twice to open the submenu. Assigning these items a -1 tabindex takes them out of the tabbing sequence completely.

comment:7 koopersmith2 years ago

  • Keywords needs-patch added; has-patch needs-testing removed

We should definitely prevent those items from opening a second time, but the issue is that the menus will no longer be tabbable when collapsed. A potential fix could unify the image and title into a single link.

comment:8 azaozz2 years ago

Looking at all the options there, not sure it's good to open the flyouts when the menu is unfolded, they aren't accessible anyways.

Leaving only the <a> tags as tabinedx-ed (default browser behavior) makes tabbing through it work pretty well:

  • flyouts are not shown,
  • the current screen submenu is expanded, so tabbing goes through all items on it,
  • other submenus are accessible after pressing Enter on the top menu item (that loads the other screen making all submenus there accessible with tabbing).

comment:9 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [19426]:

DOn't show flyouts on tabbing for now (not accessible), fixes #19191

comment:10 toscho2 years ago

  • Cc info@… added

Oh, this is bad. Searching for a menu entry requires multiple page loads now. Why is this better?

Note: See TracTickets for help on using tickets.