WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19236 closed defect (bug) (duplicate)

media-upload.php balkiness

Reported by: horike Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Media Keywords: close
Focuses: Cc:

Description

hi.

I'm japanese plugin developper horike.
I'm making plugin now, and I found this bug.

I use jQuery ui tabs and media-upload.php to making plugin on one newly-built admin page.
Then, I found that I can't post a image file to use media-upload.php .

Steps to reproduce:
1:Create to bulild a new admin page
2:You use jQuery ui tabs and media-upload.php to making plugin on one newly-built admin page.
3:You run media-upload.php

I think to conflict jQuery ui tabs and media-upload.php.
Tested in latest versions of Chrome and Firefox in Mac OS X 10.7.2 and PHP 5.3.6 , Apache2.2.17 ,MySQL 5.5.9

Attachments (1)

trust-form.zip (172.9 KB) - added by horike 2 years ago.
plugin

Download all attachments as: .zip

Change History (10)

comment:2 ocean902 years ago

  • Keywords reporter-feedback added

Could you provide please an example plugin/code?

horike2 years ago

plugin

comment:3 horike2 years ago

I ulpoaded my plugin.

Steps to reproduce:

  1. Plugin activate
  2. Click a side menu on admin page 「Trust Form」> 「Add Form」
  3. Mouse over on around「confirm」button on 「Add Form」page
  4. Click and open the popup window
  5. Click a「Select File」link on the popup window
  6. Upload file and Insert Into Post

Then Admin Screen keep black.

Last edited 2 years ago by horike (previous) (diff)

comment:4 horike2 years ago

JavaScript Code:「trust-form/js/trust-form.js」

  1. jQuery ui tabs on 11 line
  2. Media-upload.php on from 128 line to 140 line

HTML Code: 「trust-form/admin/add.php」

  1. jQuery ui tabs on 218 line
  2. Media-upload.php on 249line


comment:5 ocean902 years ago

Can you test it with current trunk again please? It works for me in Chrome. Could be r19264 or r19258.

comment:6 ocean902 years ago

  • Keywords close added

Duplicate: #19212, #19189.

comment:7 horike2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I tested [19264]. It works too me in Firefox.
Thanks you.

Last edited 2 years ago by horike (previous) (diff)

comment:8 SergeyBiryukov2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 SergeyBiryukov2 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.