Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#19259 closed feature request (duplicate)

Consider a new capability of 'add_post'

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Administration Keywords:
Focuses: Cc:


I'm hoping this isn't too niche a requirement to be considered.

On two sites recently I've wanted to prevent a user from being able to create new posts, while still allowing them access to the Posts screen and to edit their existing posts.

I can partially achieve this by giving them the edit_posts capability but not the publish_posts capability (the same as Authors). I would also like to be able to prevent them from being able to add new posts at all. The problem is that viewing the Posts screen and adding a new post uses the same capability, edit_posts.

My use case is that I have some users who have posts added and published on their behalf. They are then set as the post author so they can edit their posts if necessary.

Currently these users can still create new posts and submit them for review. It would be nice to prevent them from adding new posts at all. Currently I have to hide the various 'Add New' UI elements and prevent access to the Add New Post screen.

Change History (1)

#1 @nacin
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

+1 from me. #16714

Note: See TracTickets for help on using tickets.