Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#19262 closed defect (bug) (invalid)

Posts are not listed under "all posts"

Reported by: gnilebein Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords:
Focuses: Cc:


I moved two of my Wordpress installations from a server running Debian Lenny with PHP 5.2 to an new server running Ubuntu Lucid with PHP 5.3.

Now there is a problem that posts / pages are not listed under "All Pages" / "All Posts".

At first I did the following steps:

  1. Disabled all plugins
  2. Switched to the default theme
  3. activated wp_debug in wp-config.php

I got the following error message in backend:

Notice: Undefined property: stdClass::$post_type in /home/xxx.xxxx.de/public_html/wp-admin/includes/class-wp-posts-list-table.php on line 264

The same happens under Debian Squeeze with PHP 5.2.

When I create a new page or post, this post is not visible too.

Attachments (1)

bug.jpg (80.9 KB) - added by gnilebein 4 years ago.

Download all attachments as: .zip

Change History (8)

4 years ago


#1 follow-up: @TobiasBg
4 years ago

  • Keywords reporter-feedback added

This very likely is a problem with $PHP_SELF, judging from a lookup of the line of code mentioned in the first error message in your screenshot.
This seems to have been dealt with in #17749 and [18993].

Can you please test again with the current WordPress Trunk from SVN or the 3.3-beta3?

#2 in reply to: ↑ 1 @gnilebein
4 years ago

  • Summary changed from Posts are note listed under "all posts" to Posts are not listed under "all posts"

I think i found the cause for this issue. It's not a wordpress problem. I think it comes from the Webserver Management tool (Virtualmin) i use. I am running PHP in CGI Mode. Under Debian Lenny with PHP5.2 it works fine. This is the Output of $PHP_SELF:

Array ( [0] => /wp-admin/index.php [1] => index.php )

But under Ubuntu Lucid with PHP5.3 in cgi mode, this is the output of $PHP_SELF

Array ( )

#3 @SergeyBiryukov
4 years ago

Seems like [18993] should have fixed this?

#4 @gnilebein
4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

No, that's not the solution.

If you are using PHP 5.3 in cgi mode, adding cgi.fix_pathinfo=0 to your php.ini will fix the $PHP_SELF variable.

#5 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted

#6 @SergeyBiryukov
4 years ago

  • Keywords reporter-feedback removed
  • Resolution wontfix deleted
  • Status changed from closed to reopened

#7 @SergeyBiryukov
4 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.