WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19303 closed feature request (wontfix)

when inserting image into post the default caption should be either the title or excerpt of the imge

Reported by: mark-k Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Media Keywords:
Focuses: Cc:

Description

right now to have a caption for an image you need to upload the image, add it to the post, then edit image properties. this process requires opening two popups, and it is not obvious at all.

IMO caption should be explicitly set when the image is uploaded, or at least use a better default then "empty", the title 9which is required) might be the best, but maybe the excerpt is better, havn't made up my mind about it.

Change History (4)

comment:1 jane2 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

You are somehow missing the obvious. The caption field is in the original uploader popup, right between alt text and description. There is no need for two popups.

Many people don't add captions at all, and captions generally add large borders around images (dependent on theme). There's no way someone who uploads a 150 image gallery should have to open each image and remove default captions. Given that most image titles are something like CPS_000879 at upload, this would be a disaster. Closing wontfix.

comment:2 mark-k2 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect (bug)

haha, it is my own fault but IMHO there is still something to fix here. I am using a small plugin to remove the width and height of the full size images as I prefer to control the maximum size by CSS (which is also more theme change friendly IMO).

From code inspection it seems to me that the problem is that captions are not being set if there is no width to the image, and the only thing I can say about it at this point is WTF, especially since the filter which adds the caption is low priority, and this behavior is not documented as far my google skill goes.

comment:3 jane2 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed
  • Type changed from defect (bug) to feature request

If there's an issue with captions being tied to width, that is different from suggesting that captions be set to title by default. Please open a new ticket with your bug report. Thanks.

comment:4 ocean902 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.