WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#19341 closed defect (bug) (fixed)

Insert image from url not working on Press This

Reported by: ronbme Owned by: azaozz
Milestone: 3.3 Priority: high
Severity: normal Version: 3.3
Component: General Keywords:
Focuses: Cc:

Description

The insert image from url is not working on Press This.
If the image does not show up in the preview window, there is no other way to insert the image.

I did a copy and paste on the image location and then clicked to insert it in the post. Nothing shows up.

This is using WP 3.3. trunk 19414.

Problem has existed for all versions of WP 3.3

Change History (9)

comment:1 follow-up: @jane4 years ago

  • Keywords Insert image from url removed

@nacin: is this a regression? I have a buggy Press This now too, though wouldn't prioritize it and am not sure if it was working better in 3.2.
(Also, shouldn't we be pulling it out into a plugin? We should remember to do that.)

comment:2 @nacin4 years ago

  • Milestone changed from Awaiting Review to 3.3
  • Owner set to azaozz
  • Priority changed from normal to high
  • Status changed from new to assigned

Press This really isn't that difficult. It's just always had an ugly and neglected codebase. It should remain in core and be supplemented by browser extensions to replace the bookmarklet. It just needs the love of an enterprising developer for a single release.

It doesn't rely on the media code, it has it's own, so this wasn't broken from the media button merge work, AFAICT.

comment:3 @duck_4 years ago

Caused by [19381] which caused image_selector() to use #tb_this_photo and #tb_this_photo_description. #photo-add-url-div also uses image_selector(), but it's inputs don't have the tb_ prefix.

comment:4 in reply to: ↑ 1 @ronbme4 years ago

Replying to jane:

@nacin: is this a regression? I have a buggy Press This now too, though wouldn't prioritize it and am not sure if it was working better in 3.2.
(Also, shouldn't we be pulling it out into a plugin? We should remember to do that.)

There is a plugin named "Press This Reloaded". It actually goes further than Press This. But, unfortunately, it hasn't been updated.

comment:5 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In [19424]:

Fix inserting images from url in Press This, fixes #19341

comment:6 @nacin4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The margin: 10px pretty obviously broke styling of the stuffboxes.

comment:8 @nacin4 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [19491]:

Remove margin from h3's in press this. fixes #19341.

comment:9 @azaozz4 years ago

In [19492]:

Fix css selectors mismatch in Press This, see #19341

Note: See TracTickets for help on using tickets.