WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 8 months ago

#19375 closed defect (bug) (duplicate)

Make BLOG_ID folder deleted on site-deletion

Reported by: momotombopuro Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Multisite Keywords: has-patch
Focuses: Cc:

Description

It would be appreciated that the BLOG_ID folder get deleted on site-deletion, in the future..

My reference is the discussion at,

http://wordpress.org/support/topic/wpmu_delete_blog-not-deleting-blogsdir-folder

Attachments (1)

19375.patch (888 bytes) - added by kurtpayne 2 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 SergeyBiryukov2 years ago

  • Component changed from General to Multisite

comment:2 kurtpayne2 years ago

  • Cc kpayne@… added
  • Keywords has-patch added
  • Version set to 3.0

For removing the entire blog.dir/[id]/ folder, Ipstenu covered it pretty well in the referenced support thread. It's intended behavior.

I did find a problem in deleting folders on WAMP, though. The directory handles from opendir are not closed and this causes a problem when the directories are removed with rmdir. The warnings are suppressed with @, so it doesn't show up anywhere, just left over YYYY/MM folders.

kurtpayne2 years ago

comment:3 m_uysl2 years ago

  • Version changed from 3.0 to 3.3.1

I get this problem and tried to patch but still continue.

comment:4 jamescollins2 years ago

  • Version changed from 3.3.1 to 3.0

The version field is used to indicate the first version in which a problem was identified in, or reproduced in.

comment:5 jeremyfelt8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate as the closedir() change that resolves this was added in [21801] via #21780

Note: See TracTickets for help on using tickets.