WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#19396 closed defect (bug) (duplicate)

Featured image dialog box has "From URL" tab (which doesn't apply/work)

Reported by: Viper007Bond Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Media Keywords: has-patch
Focuses: Cc:

Description (last modified by Viper007Bond)

When you click "Set featured image", the "From URL" tab is there. While it'd be cool to be able to specify a URL for a featured image, that's not currently possible so the tab should be removed for the featured image dialog box.

Props Rok from Zemanta for the report.

Attachments (1)

19396.patch (1.3 KB) - added by SergeyBiryukov 22 months ago.

Download all attachments as: .zip

Change History (15)

comment:1 Viper007Bond2 years ago

  • Description modified (diff)

comment:2 Viper007Bond2 years ago

  • Description modified (diff)

comment:3 Viper007Bond2 years ago

  • Description modified (diff)

comment:4 nacin2 years ago

  • Milestone changed from 3.3 to Awaiting Review

Removing mistaken milestone.

comment:5 Viper007Bond2 years ago

  • Version changed from 3.3 to 3.2

Happens in 3.2 as well, possibly even further back.

comment:6 zemanta2 years ago

We have implemented setting featured images from our widget by uploading the image through ajax on our WP plugin. Would be great to have this support in WP so we could use it from our browser extension too, and people could use the URL upload!
Let us know if we can contribute anything!

comment:7 yoavf2 years ago

  • Cc yoavf added

comment:8 westi23 months ago

  • Milestone changed from Awaiting Review to Future Release

This is a good idea but to do it easily we need to start passing some form of this iframe is being displayed in context and then make it available in the filters.

This would make it easier for other plugins to disable tabs too - at the moment they have to use the media_upload_tabs filter and lame hacks based on referrers/extra query string arguments they hack into the url.

We should add a "context" arg to get_upload_iframe_src to support this which could then be passed to the media_upload_tabs filter.

comment:9 Nao23 months ago

  • Cc info@… added

comment:10 SergeyBiryukov23 months ago

Related: #18708 (has a patch for get_upload_iframe_src() context), #20632

comment:12 sabreuse22 months ago

  • Cc sabreuse@… added

SergeyBiryukov22 months ago

comment:13 SergeyBiryukov22 months ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Future Release to 3.5

19396.patch passes the context in the same way as custom-header.php, without introducing a new parameter for get_upload_iframe_src().

Or should we go with a new parameter and review our current uses of get_upload_iframe_src()?

comment:14 SergeyBiryukov22 months ago

  • Milestone 3.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Going to close this as a duplicate of #18708 (since the patches overlap more and more).

Note: See TracTickets for help on using tickets.