WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19446 closed defect (bug) (invalid)

TortoiseSVN 1.7.x Cannot Browse Plugins Repository

Reported by: arena Owned by: arena
Milestone: WordPress.org Priority: normal
Severity: normal Version:
Component: WordPress.org site Keywords:
Focuses: Cc:

Description

Hello

since several days i have a big problem to access my plugin repository
using SVN Turtoise and 'Repo Browser' option.

see screenshot attached.

Is there any svn commands that have been recently blocked ?

Attachments (1)

Capture.PNG (22.4 KB) - added by arena 2 years ago.
screenshot repo browser

Download all attachments as: .zip

Change History (20)

arena2 years ago

screenshot repo browser

comment:1 dd322 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me, Tortoise's new release takes a fair amount of time to do it's job, but it gets there eventually (And will taken even longer for those on slower internet connections).
In my particular version, I also have to enter the URL into the browser field, as it doesn't work otherwise.

Eitherway, It's not a WordPress.org change or function that's causing it, it'll be the client, and in the event an error is returned from the svn server, it'll be shown in the browser - Give it time and it'll work.

comment:2 miqrogroove2 years ago

Same problem, TortoiseSVN 1.7.1. Repo is unusable via HTTP. I can browse my own server just fine using the SVN protocol, so this problem is somewhat specific to WordPress.

comment:3 miqrogroove2 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Upgrading to 1.7.3 does not resolve this issue. dd32, please realize the repository is unusable for us. This is a valid ticket.

comment:4 dd322 years ago

  • Milestone set to WordPress.org

Can you browse the SVN server directly?
Can you browse other SVN servers via HTTP? (Try http://svn.dd32.id.au/wordpress/ )
Is it the SVN repo Browser, or all SVN actions which are failing for you?
What ISP are you using/where are you located?

comment:5 arena2 years ago

i had some issues with Tortoise SVN last release x64 and all was fixed using last nightly build

comment:6 miqrogroove2 years ago

I can browse through Chrome, yes.

I cannot browse the link you provided.

I can very easily browse http://svn.mozilla.org/

Looks like just the repo browser is broken. I can still commit files and see logs (the ones I can find without a browser).

I am using a 10 Mbps university network in Michigan.

Got a reply from TSVN mailing list. They are saying it is some kind of Apache bug o_O http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2906334

comment:7 dd322 years ago

Got a reply from TSVN mailing list. They are saying it is some kind of Apache bug o_O http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2906334

"Apache" is a software company/group, Httpd and Subversion are two products of theirs.

According to that mailing list, It's a bug in the SVN Client library which they're using (ie. The Client component of SVN which all applications use). Any client which uses that particular version of the client will have the same problem when connecting to certain servers/versions of servers.

If that's the case, other than upgrading WordPress.org servers to a version which the client library doesn't have the bug with, it's on tsvn to update to fix the problem (either by patching the svn library themselves, or using a version that's not affected by the bug)..

comment:8 dd322 years ago

See also: TortoiseSVN bug: Large repo's are slow to browse - ie. plugins.svn.wordpress.org

Just to confirm: With 1.7.1 (which i was running at the time of closing this) and 1.7.2 (which i was running yesterday) - both 64bit, i wasn't seeing a problem I've just updated to 1.7.3, and I'm seeing the hanging issue, It seems to be related to the above issue, I'm seeing TortoiseSVN querying for info on every single plugin folder, when browsing a specific plugin.. It'll take some time for these ~100,000 HTTP requests to complete to show me the folder i was interested in.

The directory does open eventually.. just it takes some time for all those plugin folders to be queried.

According to that mailing list, It's a bug in the SVN Client library which they're using

Just in case it wasn't clear, That was my interpretation of the mailing list posts, I've not confirmed that, nor can i find a bug in subversions bug tracker that relates to it.

comment:9 dd322 years ago

Dave on the tortoise mailing list seems to have come to the same conclusion, it's not a bug in the library, it's the way the directories are being listed.

I might not have realised how long i had left the plugin browser loading - so didn't notice the delay..

comment:10 miqrogroove2 years ago

Yes these are good ideas. Now if we could just edit an option somewhere ... :P

comment:12 miqrogroove2 years ago

  • Summary changed from Access to svn repository with SVN Turtoise ? to TortoiseSVN 1.7.x Cannot Browse Plugins Repository

comment:13 miqrogroove2 years ago

Disregard this reply :)

Last edited 2 years ago by miqrogroove (previous) (diff)

comment:14 dd322 years ago

It looks like the changes in the bug i mentioned above will fix this for TortoiseSVN users.

For cross-referencing purposes, here's some discussion about large repo's (such as the plugins directory) and performance: http://svn.haxx.se/dev/archive-2012-01/0053.shtml

comment:15 miqrogroove2 years ago

Version 1.7.4 has been released and remains broken. I can't really tell if it's going slightly faster or not, but is still listing every directory in the repository when I try to browse a trunk subdir.

comment:16 miqrogroove2 years ago

After some extremely patient testing I'm giving up on 1.7.4. In some cases the browser will initialize if I don't touch it for 2 to 3 minutes. About half the time it fails to initialize and either nothing happens or I get an error message, "There has been a problem contacting the server." Useless.

comment:17 azaozz2 years ago

  • Keywords close added; 2nd-opinion removed

Yes, seems TortoiseSVN's repo browser still doesn't work well. BTW why would you use it? It has always been quite slow at least in my experience. Also the plugins repo can be browsed with a web browser too (and that works well).

In any case this is a problem with only one part of TortoiseSVN, all the rest seems to work well. Don't see what we can do to fix it.

comment:18 miqrogroove2 years ago

The latest messages at the tsvn forum seem to acknowledge a behavioral change in 1.7.x that breaks the repo browser when many projects exist. However, they seem more interested in blaming the WordPress server design than fixing the repo browser.

comment:19 arena2 years ago

  • Keywords close removed
  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.