WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#19447 closed defect (bug) (duplicate)

Image uploads fails with % symbol in filename

Reported by: peterhol Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Upload Keywords:
Focuses: Cc:

Description

When uploading images with percentage sign in the filename (%), the image is not shown in the media library, and the url doesn't work… (the url keeps the % sign, guess that's why it doesn't work)

Attachments (2)

28500.diff~ (803 bytes) - added by UmeshSingla 5 years ago.
Fixes Filename with %
20%Internet-Uses-Wordpress.png (471.2 KB) - added by UmeshSingla 5 years ago.
Sample image with filename to replicate the issue

Download all attachments as: .zip

Change History (7)

#1 @peterhol
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry! didn't see this: #16226

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

#2 @helenyhou
8 years ago

  • Milestone Awaiting Review deleted

@UmeshSingla
5 years ago

Fixes Filename with %

#3 @UmeshSingla
5 years ago

  • Focuses accessibility added
  • Keywords has-patch added
  • Resolution duplicate deleted
  • Status changed from closed to reopened

#16330 doesn't fixes the issue with % in filename.

If I upload a image containing % in its name, image is broken. The URL doesn't works.

I'v included % in special characters list to fix the uploads.

Attaching a sample image.

@UmeshSingla
5 years ago

Sample image with filename to replicate the issue

#4 @SergeyBiryukov
5 years ago

  • Focuses accessibility removed
  • Milestone set to Awaiting Review

#5 @ocean90
4 years ago

  • Keywords has-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #16226.

Note: See TracTickets for help on using tickets.