WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 20 months ago

#19454 closed defect (bug) (fixed)

Encoding errors in plugins updating subsystem

Reported by: sergey.s.betke@… Owned by: sergey.s.betke@…
Milestone: 3.5 Priority: normal
Severity: normal Version: 3.2.1
Component: Upgrade/Install Keywords: has-patch dev-feedback
Focuses: Cc:

Description

When the option default_charset in php.ini (for example - windows-1251) other than blog encoding (for example - UTF-8), whe have troubles.

WordPress version

Latest WordPress files - 3.3-RC1-19537

browser

MS IE9, Google Chrome

Reproducing the problems

  • set in php.ini (or in htaccess) default_charset to windows-1251 (or any other, not UTF-8 in this example)
  • set wordpress option blog_charset to UTF-8
  • go to /wp-admin/update-core.php
  • update Your plugins. I see wrong encoding in iframe.

plugins and themes

This trouble is exist on default wordpress installation, with any plugins, on default theme

Test environment

  • IIS 7
  • PHP 5.3.6
  • MySQL 5.1
  • proxy - MS ISA Server
  • Test server - http://test.www.novgaro.ru, account - testuser, password - testuser. (You can login to this test server).

Attachments (5)

19454.diff (379 bytes) - added by sergey.s.betke@… 2 years ago.
19454.iframe.png (38.8 KB) - added by SergeyBiryukov 21 months ago.
19454.2.diff (491 bytes) - added by SergeyBiryukov 21 months ago.
19454.charset-only.diff (446 bytes) - added by SergeyBiryukov 21 months ago.
19454.3.diff (522 bytes) - added by SergeyBiryukov 20 months ago.

Download all attachments as: .zip

Change History (13)

comment:1 knutsp2 years ago

  • Cc knut@… added

sergey.s.betke@…2 years ago

comment:2 sergey.s.betke@…2 years ago

  • Keywords needs-testing added

comment:3 sergey.s.betke@…2 years ago

  • Keywords needs-testing removed

SergeyBiryukov21 months ago

comment:4 SergeyBiryukov21 months ago

  • Milestone changed from Awaiting Review to 3.5

Confirmed on Apache 2.2.4 with PHP 5.2.14 as well: 19454.iframe.png.

AddDefaultCharset utf-8 in .htaccess doesn't help.

19454.2.diff is the refreshed patch. Not sure if the additional headers are necessary though. 19454.charset-only.diff just fixes the charset issue.

comment:6 ryan20 months ago

Moving things into _wp_admin_html_begin() can result in dupes. The six places that call this function need to be audited.

SergeyBiryukov20 months ago

comment:7 SergeyBiryukov20 months ago

19454.3.diff only adds the charset to iframe_header(). The rest appears to be already handled.

comment:8 ryan20 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In [21538]:

Send Content-Type with charset for iframe_header(). Props SergeyBiryukov, sergey.s.betke@…. fixes #19454

Note: See TracTickets for help on using tickets.