WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#19482 closed defect (bug) (duplicate)

Cannot link a floated image in visual editor

Reported by: jcross Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I have tried this in WP 3.2.1 and 3.3RC2 with the same results in both.

Create a new post or page, then do the following in the page's content box (in the visual editor):

  1. Upload an image, or select one already in your media library
  2. Float the image (left, right, or center)
  3. Empty the Link URL field
  4. "Insert into post" button
  5. Click the image you just placed. Click Edit Image icon that overlays on image.
  6. Add a URL to a website or file, or click “link to image” in the URL field.

8 Click Update. Then, either look at the HTML or edit the image again to confirm if the tag has been wrapped appropriately.

In my experience, the combo of floating an image without a URL, then trying to add a URL after the fact results in the editor not wrapping the <img> in the appropriate anchor tags.

Can anyone else confirm this?

Change History (3)

#1 @SergeyBiryukov
9 years ago

Sounds like a duplicate of #16569 and #19468?

Last edited 9 years ago by SergeyBiryukov (previous) (diff)

#2 @jcross
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Confirmed. It's only in webkit also, as mentioned those tickets.

#3 @helenyhou
9 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.