WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#19488 closed defect (bug) (worksforme)

RSS Feed Sort Issue When Excluding Categories

Reported by: frank13 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Feeds Keywords: reporter-feedback
Focuses: Cc:

Description

When you exclude a category in the query string of an RSS feed the result set is not sorted most recent to oldest as it used to prior to version 3.2.1

http://mydomain.com/blogs/feed/?cat=1 (shows only category 1 and sorts latest to oldest)

http://mydomain.com/blogs/feed/?cat=-1 (excludes category 1 but does not sort latest to oldest)

Change History (3)

comment:1 @solarissmoke3 years ago

  • Keywords reporter-feedback added

I can't reproduce this in 3.2.1 or trunk - it always sorts by date created descending, even when I exclude a category. Can you confirm that this happens on a clean install of WordPress with no plugins installed?

comment:2 @midhund3 years ago

I also got the same issue on trunk, but on my 2nd installation from trunk was fine and not able to reproduce the issue.

comment:3 @SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

Could not reproduce in trunk.

Note: See TracTickets for help on using tickets.