WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 8 months ago

#19497 closed enhancement (wontfix)

The 'My Sites' menu is redundant for users with just one site

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Multisite Keywords:
Focuses: Cc:

Description

When a user only belongs to one site in a multisite install, they're shown a 'My Sites' menu. All of the items in this menu in this scenario are redundant (both in the admin area and when viewing the site) as all four menu items can be accessed from other menus in the toolbar.

Users shouldn't be shown this menu unless they belong to two or more sites.

I know we're on RC2 but I'd love to get this into 3.3 because it looks a bit silly.

Attachments (2)

19497.patch (498 bytes) - added by johnbillion 2 years ago.
19535.patch (570 bytes) - added by johnjamesjacoby 2 years ago.
From my #19535 duplicate

Download all attachments as: .zip

Change History (10)

johnbillion2 years ago

comment:1 johnbillion2 years ago

  • Keywords has-patch added

Patch

comment:2 johnbillion2 years ago

  • Keywords has-patch removed
  • Type changed from defect (bug) to enhancement

Hmm, the user still needs that menu when they're browsing other sites in the network. Maybe only hide it when they're on the site they belong to. Not sure.

comment:3 duck_2 years ago

This is intentional, see #19122 and Jane's comment in particular.

comment:4 scribu2 years ago

  • Keywords ux-feedback added

I don't think Jane's comment addresses this case.

comment:5 nacin2 years ago

yes, my sites should always be there if they have sites on the network

Having a consistent menu is likely better than only showing it in particular situations. I think that's what Jane was trying to get across.

comment:6 jane2 years ago

  • Component changed from Admin Bar to Multisite
  • Keywords ux-feedback removed
  • Milestone changed from Awaiting Review to Future Release

"the user still needs that menu when they're browsing other sites in the network." << Correct.

"Maybe only hide it when they're on the site they belong to." << Disappearing menus is confusing.

While I agree that My Sites is superfluous in the case of only having a role on one site, I'm not down with changing it this late in the game. We're overdue for a release focused on making multisite better, and this issue can be addressed in 3.4 or later. It's not a regression, it's not a bug.

johnjamesjacoby2 years ago

From my #19535 duplicate

comment:7 ciantic2 years ago

  • Cc ciantic@… added

comment:8 jeremyfelt8 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Per ux-feedback:

Disappearing menus is confusing

Note: See TracTickets for help on using tickets.