WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19506 closed defect (bug) (invalid)

Table Collation updates do not affect rows in WP 3.2.1

Reported by: misty9 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords:
Focuses: Cc:

Description

Issue: After updating Collation of the Wordpress tables, non of the rows in the tables are updated accordingly in WP 3.2.1

Click on Operations tab of table wp_posts, replace "latin1_swedish_ci" "utf8_general_ci" in Collation field for wp_posts.

However, the rows of wp_posts of Collation remain "latin1_swedish_ci". I'd like to know if this is intended behavior? Thanks.

(Here is my question at on the Troubleshoot forums regarding this issue.
http://wordpress.org/support/topic/how-fix-black-diamond-question-marks-in-wp-321?replies=2#post-2491861)

Change History (2)

comment:1 SergeyBiryukov2 years ago

Altering a table does not automatically convert the character set of the columns contained in the table. See http://codex.wordpress.org/Converting_Database_Character_Sets.

comment:2 dd322 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Nor is this a WordPress specific issue, it's a MySQL Database configuration item.

As SergeyBiryukov points out, you'll have to change the Database, Table, and Fields most likely, although some tools may alter them all in one hit.

Closing as invalid.

Note: See TracTickets for help on using tickets.