WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#19516 closed defect (bug) (invalid)

Unable to edit uploaded images

Reported by: gwendydd Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

On one WordPress site that I am developing, I cannot edit uploaded images. When I open up the "edit image" dialog box, there should be an image there on the left that I can edit, but I just have a blank box. You can see a screenshot here:
http://gbd.alchemycs.com/wp-content/uploads/2011/11/thumbnail-problem2.jpg

If I click one of the buttons to rotate the image or otherwise alter it, it just hangs with the spinning mouse icon, and nothing else ever happens.

I had a conversation about this with a plugin developer on the support forum:
http://wordpress.org/support/topic/plugin-post-thumbnail-editor-no-image-on-the-left-to-crop

I have disabled all plugins, and it still happens. I'm using WordPress 3.2.1.

Change History (6)

comment:1 @gwendydd3 years ago

I was hoping that 3.3 would fix my problem, but it didn't.

comment:2 @kurtpayne3 years ago

  • Cc kpayne@… added
  • Keywords reporter-feedback added

What browser are you using when this happens?

Can you reproduce this with every image you try, or only this one? Is it on every browser? Is it on every workstation?

I tested this with 3.3 in IE9, FF8, Safari 5, Opera 11, and Chrome 15. I wasn't able to reproduce this.

comment:3 @gwendydd3 years ago

Every browser, every computer, every image. But only on one particular website:
http://gbd.alchemycs.com

All other websites I have developed have no problems editing images.

However, I may have just discovered the source of the problem... I switched themes, and in TwentyTen, it works fine. So there must be something wrong with my theme that is preventing me from editing images. It is a theme that I wrote from scratch 2 years ago when I was first learning WP development. Do you have any ideas about what might be in the theme (or missing from it) that would cause this?

comment:4 @kurtpayne3 years ago

Do you have any errors in your error log? Can you post a screencap of what's happening?

comment:5 @gwendydd3 years ago

The error log is clean. The picture I provided in my first post shows you what happens:
http://gbd.alchemycs.com/wp-content/uploads/2011/11/thumbnail-problem2.jpg
There should be an image in that blank space on the left, and there isn't. If I click one of the editing buttons (such as a rotate button), the mouse becomes a spinning wheel and it never stops spinning - nothing else happens.

At this point, it's looking like a bug in my theme, not WordPress, so this might be an issue for the support forums. If you don't want to pursue it any further here, that's fine wth me.

comment:6 @helenyhou3 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.