WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#19533 closed defect (bug) (invalid)

Word Count isn't updated anymore

Reported by: Confridin Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.3
Component: Editor Keywords:
Focuses: Cc:

Description

The word count below the post editor isn't counting words anymore.

It can be fixed by changing this file : wp-admin/js/word-count.js.

.word-count has to be replaced by #wp-word-count.

Regards,

Change History (5)

comment:1 Confridin2 years ago

Here is my french tutoriel to correct wordpress word count : http://www.seomix.fr/wordpress/hack/compteur-de-mots/

comment:2 helenyhou2 years ago

  • Keywords reporter-feedback added; has-patch removed

I can't seem to reproduce - I do get the word count after some delay, which was how it worked for me in 3.2.1. Making the change as you suggested (and you shouldn't be advocating the hacking of core in a tutorial) does not fix anything and ends up just showing a number without text in the corner because it's targeting the wrong thing.

comment:3 Confridin2 years ago

I know it's better not to hack the core, but many users need the word count. For example, i know dozens of wordpress blog that use this CMS to create a digglike, and the word count is really useful.
In my case, it fixed immediately the issue.

Here is another solution : http://bp-fr.net/2011/12/remise-en-route-du-compteur-de-mot-de-wordpress/

I know it also hacks the core, but the core should correct this bug in next version 3.3.1

We all use the french version of WordPress.

comment:4 Confridin2 years ago

A french user just explained that is not a bug from WordPress Core, but from the french translation.

"Word count: %s" is translated in "Compteur de mots : %d" instead of "Compteur de mots : %s".

I've update my tutorial.

comment:5 SergeyBiryukov2 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.