WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19536 closed defect (bug) (invalid)

Search returns draft posts

Reported by: y2kemo Owned by: y2kemo
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: General Keywords:
Focuses: Cc:

Description

When searching my site I am able to return draft posts in the search results. I don't know if this is a theme issue, or a WordPress issue, but it's an issue.

My site is y2kemo.com

If you search for WordPress you will see an "Honorable mentions" post. That post has not been published. If you click on it you will get a 404.

Change History (3)

comment:1 @justindgivens3 years ago

I'm not seeing that post displayed. If you are it might be because you are logged in.

comment:2 @solarissmoke3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Draft posts should not appear on the front-end search even if you are logged in.

Looking at the site (where I too am not seeing that post appear in results), I suspect it was a caching issue as you have a caching plugin installed (you might have briefly published that post before unpublishing it again?).

Feel free to reopen with steps to reproduce if it still happens with all plugins disabled.

comment:3 @scribu3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.