WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 16 months ago

#19559 closed defect (bug) (worksforme)

wp_login_form + is_user_logged_in don't work anymore

Reported by: Dukessa Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Users Keywords: reporter-feedback
Focuses: Cc:

Description

I haven't debugged this enough to give you more precise details, however, all frontend login forms (except on standard wp-login.php) output through wp_login_form, do not work anymore, right after upgrade to 3.3

Moreover, correctly logged in user, still isn't recognized, nor with cookies, not by is_user_logged_in

Basic tests have been performed such as flushing cache and cookies, on different browsers and disabling plugins. No difference.

Change History (4)

comment:1 Dukessa2 years ago

Same issue with:

$current_user = wp_get_current_user();
if ( 0 == $current_user->ID ) {
    // Not logged in.
} else {
    // Logged in.
}

Are we missing important documentation here, or is it really a bug?

Last edited 2 years ago by Dukessa (previous) (diff)

comment:2 kawauso2 years ago

  • Keywords reporter-feedback added

Can't reproduce either issue on 3.3 with Twenty Eleven and the 'wp_head' action hook. Does it still occur with the Twenty Eleven theme?

comment:3 MattyRob2 years ago

wp_get_current_user() is working fine for me.

wp_get_current_user() and get_currentuserinfo() can both be plugged, is it possible you are using a plugin that is over riding the default functions and breaking them?

Can you deactivate all plugins in your testing and still reproduce?

comment:4 SergeyBiryukov16 months ago

  • Component changed from General to Users
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed

No feedback in 12 months.

Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.