WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#19582 closed defect (bug) (worksforme)

post page always reverts back to html tab

Reported by: youthgas Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Editor Keywords:
Focuses: Cc:

Description

First bug report. Hope it is ok.

So... not matter what I do, the post page starts on and reverts on the html tab. I want a new post, it opens on that tab and not the visual.

I move to the visual tab and create post. Save post and it reverts itself back to the html tab, when I would like it to stay on the visual tab.

Change History (12)

comment:1 @solarissmoke4 years ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added

What browser/version/operating system are you running?

comment:2 @youthgas4 years ago

FF / 8 / Win 7

It was also on 3.2.1 but I left it to 3.3 to see if the upgrade would catch it. I don't think it was in 3.2.

The upgrade to 3.3 did catch a previous issue where the dashboard and pages menus on the left would continuously reopen regardless of whatever page I was on.

comment:3 @youthgas4 years ago

  • Keywords reporter-feedback removed

comment:4 @solarissmoke4 years ago

I've just tested on a clean install of WP 3.3 with exactly the same platform, and it works fine for me. Can you reproduce this with all plugins disabled?

comment:5 @youthgas4 years ago

Only use a few plugins which I just disabled.

Went to random recent post and it opened in html tab. Changed to visual tab. I saved it and it went back to html tab.

Went to open a new post and it opened in html tab.

All plugins were disabled throughout.

comment:6 @solarissmoke4 years ago

The choice of editor is saved using Javascript + cookies. Do you have any add-ons installed on FF that might be interfering? Maybe try a different browser altogether to see whether it still happens.

comment:7 @youthgas4 years ago

FF has no addons.

Tried IE9, same problem.

On a hunch, I tried deleting my site's cookies on FF but did nothing.

comment:8 @SergeyBiryukov4 years ago

Is there a chance some firewall rule or antivirus software partly blocks JavaScript code?

comment:9 @youthgas4 years ago

I am not aware of anything blocking anything.

comment:10 @youthgas3 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

I ended up doing a complete reinstall and it was fixed / reverted back to normal behaviour.

I guess it's safe to close this.

comment:11 @SergeyBiryukov3 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:12 @SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.