WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#19591 closed defect (bug) (duplicate)

Filtered exports drop attachments

Reported by: ddeconin Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Export Keywords:
Focuses: Cc:

Description

WHen I export a couple of blog posts from my main blog www.verteleens.be to my development blog dev.verteleens.be the images are not copied into the media library.
Can be reproduced by trying to load the attached xml in a blog

Attachments (1)

verteleens.wordpress.2011-12-17.xml (176.0 KB) - added by ddeconin 4 years ago.
Example file that fails to import the images in the media library

Download all attachments as: .zip

Change History (4)

@ddeconin4 years ago

Example file that fails to import the images in the media library

comment:1 @duck_4 years ago

No attachments are imported because there are no attachments defined in the export file. I assume this is because you filtered your export to only output some a set of posts. Currently attachments are only exported when you choose "All content", so this is an export problem rather than an import one (and there might be a ticket for it already).

comment:2 @ddeconin4 years ago

Ok, but when I do all content I get a file that's way to big to export/import...

comment:3 @duck_3 years ago

  • Component changed from Import to Export
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from wordpress importer 0.5 fails to import images to media library to Filtered exports drop attachments
  • Version changed from 3.3 to 3.0

Marking as duplicate of #17379. Also related is #19307.

Note: See TracTickets for help on using tickets.