WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#19613 closed defect (bug) (fixed)

Select menus with long items overflow panels in the admin

Reported by: Master Jake Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: normal Version: 3.3
Component: UI Keywords: has-patch dev-reviewed commit
Focuses: Cc:

Description

In the WordPress Admin, select menus which have long options may exceed the width of their parent meta box container.

Related ticket: #15114

Attachments (7)

Screen shot 2011-12-19 at 11.35.37 AM.png (34.7 KB) - added by Master Jake 4 years ago.
Screen shot 2011-12-19 at 11.36.13 AM.png (37.2 KB) - added by Master Jake 4 years ago.
wp-admin.dev.css.diff (291 bytes) - added by Master Jake 4 years ago.
19613.actions-ie8.png (10.0 KB) - added by SergeyBiryukov 3 years ago.
19613.patch (546 bytes) - added by SergeyBiryukov 3 years ago.
19613.2.patch (361 bytes) - added by SergeyBiryukov 3 years ago.
19613.quick-edit-ie8.png (4.1 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 @johnbillion4 years ago

This has been reported before. I think it may be a regression. See #17043 from 5 months ago which is marked as fixed, and #3752.

comment:2 @Master Jake4 years ago

Ah, you're absolutely right. What exactly do you mean by a regression though? Will the patch you linked to perhaps be included in the next WordPress version?

comment:3 @SergeyBiryukov4 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.4
  • Owner changed from Master Jake to azaozz
  • Status changed from new to reviewing

It was added in [18453], but then removed in [18975] (not sure what the exact issue was):
http://core.trac.wordpress.org/changeset/18453#file1
http://core.trac.wordpress.org/changeset/18975#file10

Perhaps a more specific selector is needed here?

comment:4 @ocean903 years ago

Duplicate: #19782

comment:5 @azaozz3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In [20626]:

Put back "max-width: 100%" for all <select> in the admin. Doesn't seem to work for IE7 but doesn't seem to break anything either. Props Master Jake, fixes #19613

@SergeyBiryukov3 years ago

@SergeyBiryukov3 years ago

comment:6 @SergeyBiryukov3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This breaks the action selects in IE 8 (19613.actions-ie8.png).

19613.patch sets max-width for parent page select only (which seems to be the main issue here).

19613.2.patch just fixes the action selects.

comment:7 follow-up: @SergeyBiryukov3 years ago

Just noticed that the selects in Quick Edit are also moved to a second line in IE 8 (19613.quick-edit-ie8.png), so 19613.patch is probably safer.

comment:8 in reply to: ↑ 7 ; follow-up: @azaozz3 years ago

  • Keywords commit added

Replying to SergeyBiryukov:

...19613.patch is probably safer.

Agreed. On the other hand I'm pretty sure we tested this in IE8 before, wondering what has changed... Anyways, +1 for 19613.patch.

comment:9 in reply to: ↑ 8 @westi3 years ago

  • Keywords dev-reviewed added

Replying to azaozz:

Replying to SergeyBiryukov:

...19613.patch is probably safer.

Agreed. On the other hand I'm pretty sure we tested this in IE8 before, wondering what has changed... Anyways, +1 for 19613.patch.

The patch looks good to me to - moving to a more targeted fix for the original issue.

comment:10 @azaozz3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [21042]:

When using the max-width: 100% fix for <select> tags that exceed the width of parent elements, add it only on affected tags. IE8 doesn't like it everywhere, props SergeyBiryukov, fixes #19613

Note: See TracTickets for help on using tickets.