WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#19650 closed defect (bug) (invalid)

apply_filters( 'manage_users_column' ) or equivalent no longer exists

Reported by: danielbachhuber Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: General Keywords:
Focuses: Cc:

Description

For the Users WP_List_Table, apply_filters( 'manage_users_custom_column' ) still exists but there's no apply_filters( 'manage_users_column' ) or equivalent.

This used to be handled by get_column_headers(). The function was moved to screen.php where it's only applied if the columns aren't already set. For whatever reason, the columns are already set.

We should apply it when the columns are set too. Patch attached always applies the filters

Attachments (1)

alwaysapplyfilters.patch (622 bytes) - added by danielbachhuber 3 years ago.
Always apply the manage_*_columns filters

Download all attachments as: .zip

Change History (3)

@danielbachhuber3 years ago

Always apply the manage_*_columns filters

comment:1 @danielbachhuber3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

As it turns out, core does apply the filter once and I can no longer reproduce this issue that originally prompted this ticket. Closing as invalid.

comment:2 @kawauso3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.