WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#19678 closed enhancement (duplicate)

Add attachment editing filters to Edit Image thickbox view

Reported by: kevinlearynet Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords: dev-feedback
Focuses: Cc:

Description

Changes made to media attachment fields using the attachment_fields_to_edit and attachment_fields_to_save filters are not added to the Edit Image / Advanced Settings ThickBox view that appears when an existing image is editted in TinyMCE.

Steps to Reproduce:

  • Add image to post and save post
  • Edit post, and click the 'edit image' icon in order to edit the image while it's in the post

Associated Files

Form fields used for this view are set and processed by these 2 files:

  • wp-includes/js/tinymce/plugins/wpeditimage/js/editimage.dev.js
  • wp-includes/js/tinymce/plugins/wpeditimage/editimage.html

Unfortunately I can't think of a way to to patch it elegantly.

Change History (4)

#1 @nacin
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is going to be handled by #21390, which is going to kill off this TinyMCE popup.

#2 @rodrigosprimo
4 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

It seems to me that this issue wasn't handled by #21390. Fields added using attachment_fields_to_edit and attachment_fields_to_save filters are still not displayed in the Image Details modal so I'm reopening this ticket.

#3 follow-up: @helen
4 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #21390.

@rodrigosprimo The Image Details modal does not edit attachments, but rather manages the details for the image as a part of the HTML content. It's a little confusing, but this is expected behavior. Feel free to respond with more details if I'm missing something, but please don't reopen this ticket since it's specific to the old popup.

#4 in reply to: ↑ 3 @rodrigosprimo
4 years ago

Thanks for the clarification @helen. I agree that it is a little confusing. Do you know if there is another open ticket to discuss ways to improve this?

Note: See TracTickets for help on using tickets.